summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLee Garrett <lgarrett@rocketjump.eu>2022-06-14 01:19:49 +0200
committerLee Garrett <lgarrett@rocketjump.eu>2022-06-14 16:06:09 +0200
commit106a69b74ababad6c2493d206c1efb25f0f76558 (patch)
tree957d9617b69bff9d1bf14e08b807853b2600a0e5
parent4fd7fcf2097dbdbccc4669335012dc4bfaba1f62 (diff)
downloaddebian-ansible-core-106a69b74ababad6c2493d206c1efb25f0f76558.zip
Correctly build man pages
The docs build system changed in 2.13 (again), we need to run `make docs` again.
-rwxr-xr-xdebian/rules19
1 files changed, 11 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 954fed95..b6946211 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,9 @@ export PYBUILD_DESTDIR=debian/tmp
# Make it easier to build on machines with ansible << 2.10 installed.
export ANSIBLE_SKIP_CONFLICT_CHECK=1
+# tmpdir is needed during docs build, as ~ isn't writeable in sbuild
+export ANSIBLE_LOCAL_TEMP=tmp/
+
%:
# dh $@ --with python3,sphinxdoc --buildsystem=pybuild
dh $@ --with python3 --buildsystem=pybuild
@@ -15,14 +18,14 @@ override_dh_clean:
--exclude=test/units/inventory_test_data/group_vars/noparse/all.yml~ \
--exclude=test/integration/targets/collections/collection_root_user/ansible_collections/testns/testcoll/plugins/modules/uses_leaf_mu_flat_import.bak
-#override_dh_auto_build:
-# dh_auto_build
-#ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
-# # html documentation
-# $(MAKE) webdocs
-# # manpage documentation
-# $(MAKE) docs
-#endif
+override_dh_auto_build:
+ dh_auto_build
+ # manpage documentation
+ $(MAKE) docs
+ifneq (,$(filter ansible-doc,$(DOPACKAGES)))
+ # html documentation
+ $(MAKE) webdocs
+endif
override_dh_auto_test:
# For now, disable the tests