summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLee Garrett <lgarrett@rocketjump.eu>2021-09-30 00:27:31 +0200
committerLee Garrett <lgarrett@rocketjump.eu>2021-09-30 00:27:31 +0200
commit25d5a037c91da23f751aa691e21f3494b3655553 (patch)
tree0e158a80eeeec63f8a126e8967e7950ddfb10cd2
parent178613461b6a2739df309550a82b1fd4b34f0c7a (diff)
downloaddebian-ansible-core-25d5a037c91da23f751aa691e21f3494b3655553.zip
Refreshen patches
0006-remove-sphinx-notfound.patch is obsolete as upstream has rewritten docs again. 0007-fix-interpreter-fallback.patch has been merged upstream.
-rw-r--r--debian/patches/0005-use-py3.patch59
-rw-r--r--debian/patches/0006-remove-sphinx-notfound.patch12
-rw-r--r--debian/patches/0007-fix-interpreter-fallback.patch23
-rw-r--r--debian/patches/series2
4 files changed, 25 insertions, 71 deletions
diff --git a/debian/patches/0005-use-py3.patch b/debian/patches/0005-use-py3.patch
index 1927d134..06c9521f 100644
--- a/debian/patches/0005-use-py3.patch
+++ b/debian/patches/0005-use-py3.patch
@@ -10,17 +10,6 @@ Description: use py3
# To run this script, first make webdocs in the toplevel of the checkout. This will generate all
# rst files from their sources. Then run this script ./docs/bin/find-plugin-refs.py
---- a/Makefile
-+++ b/Makefile
-@@ -30,7 +30,7 @@
- ASCII2MAN = @echo "ERROR: rst2man from docutils command is not installed but is required to build $(MANPAGES)" && exit 1
- endif
-
--PYTHON=python
-+PYTHON=python3
- GENERATE_CLI = hacking/build-ansible.py generate-man
-
- # fetch version from project release.py as single source-of-truth
--- a/lib/ansible/cli/scripts/ansible_cli_stub.py
+++ b/lib/ansible/cli/scripts/ansible_cli_stub.py
@@ -1,4 +1,4 @@
@@ -75,8 +64,8 @@ Description: use py3
-#!/usr/bin/env python
+#!/usr/bin/env python3
- import grp
-
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
--- a/test/integration/targets/module_utils/module_utils/foo.py
+++ b/test/integration/targets/module_utils/module_utils/foo.py
@@ -1,3 +1,3 @@
@@ -118,16 +107,16 @@ Description: use py3
-#!/usr/bin/env python
+#!/usr/bin/env python3
- import os
- import pexpect
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
--- a/test/integration/targets/pip/files/setup.py
+++ b/test/integration/targets/pip/files/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
- from setuptools import setup, find_packages
-
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
--- a/test/integration/targets/service/files/ansible_test_service.py
+++ b/test/integration/targets/service/files/ansible_test_service.py
@@ -1,4 +1,4 @@
@@ -142,16 +131,16 @@ Description: use py3
-#!/usr/bin/env python
+#!/usr/bin/env python3
-
- import sys
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
--- a/test/integration/targets/template/role_filter/filter_plugins/myplugin.py
+++ b/test/integration/targets/template/role_filter/filter_plugins/myplugin.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
-
- class FilterModule(object):
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
--- a/test/integration/targets/throttle/test_throttle.py
+++ b/test/integration/targets/throttle/test_throttle.py
@@ -1,4 +1,4 @@
@@ -191,7 +180,7 @@ Description: use py3
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
- ANSIBLE_METADATA = {'status': ['preview'],
+ from __future__ import (absolute_import, division, print_function)
--- a/test/lib/ansible_test/_data/cli/ansible_test_cli_stub.py
+++ b/test/lib/ansible_test/_data/cli/ansible_test_cli_stub.py
@@ -1,4 +1,4 @@
@@ -527,8 +516,8 @@ Description: use py3
-#!/usr/bin/env python
+#!/usr/bin/env python3
- import os
- import pexpect
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
--- a/test/integration/targets/cli/test_k_and_K.py
+++ b/test/integration/targets/cli/test_k_and_K.py
@@ -1,4 +1,4 @@
@@ -553,14 +542,6 @@ Description: use py3
from __future__ import (absolute_import, division, print_function)
__metaclass__ = type
---- a/test/lib/ansible_test/_data/sanity/code-smell/runtime-metadata.py
-+++ b/test/lib/ansible_test/_data/sanity/code-smell/runtime-metadata.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """Schema validation of ansible-base's ansible_builtin_runtime.yml and collection's meta/runtime.yml"""
- from __future__ import (absolute_import, division, print_function)
- __metaclass__ = type
--- a/test/lib/ansible_test/_data/sslcheck.py
+++ b/test/lib/ansible_test/_data/sslcheck.py
@@ -1,4 +1,4 @@
@@ -617,7 +598,7 @@ Description: use py3
[ "$(grep -c 'TEST COMPLETE' block_test.out)" = "$(grep -E '^[0-9]+ plays in' block_test_wo_colors.out | cut -f1 -d' ')" ]
--- a/test/integration/targets/plugin_config_for_inventory/runme.sh
+++ b/test/integration/targets/plugin_config_for_inventory/runme.sh
-@@ -7,10 +7,10 @@
+@@ -7,12 +7,12 @@
# check default values
ansible-inventory --list -i ./config_without_parameter.yml --export | \
@@ -630,6 +611,8 @@ Description: use py3
- env python -c "import json, sys; inv = json.loads(sys.stdin.read()); \
+ env python3 -c "import json, sys; inv = json.loads(sys.stdin.read()); \
assert set(inv['_meta']['hostvars']['test_host']['departments']) == set(['paris'])"
+
+ export ANSIBLE_CACHE_PLUGINS=cache_plugins/
--- a/docs/docsite/Makefile
+++ b/docs/docsite/Makefile
@@ -1,5 +1,5 @@
@@ -639,7 +622,7 @@ Description: use py3
PLUGIN_FORMATTER=../../hacking/build-ansible.py docs-build
TESTING_FORMATTER=../bin/testing_formatter.sh
KEYWORD_DUMPER=../../hacking/build-ansible.py document-keywords
-@@ -34,7 +34,7 @@
+@@ -45,7 +45,7 @@
DOC_PLUGINS ?= become cache callback cliconf connection httpapi inventory lookup netconf shell strategy vars
@@ -648,3 +631,11 @@ Description: use py3
# fetch version from project release.py as single source-of-truth
VERSION := $(shell $(PYTHON) ../../packaging/release/versionhelper/version_helper.py --raw || echo error)
ifeq ($(findstring error,$(VERSION)), error)
+--- a/test/lib/ansible_test/_data/sanity/code-smell/runtime-metadata.py
++++ b/test/lib/ansible_test/_data/sanity/code-smell/runtime-metadata.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ """Schema validation of ansible-core's ansible_builtin_runtime.yml and collection's meta/runtime.yml"""
+ from __future__ import (absolute_import, division, print_function)
+ __metaclass__ = type
diff --git a/debian/patches/0006-remove-sphinx-notfound.patch b/debian/patches/0006-remove-sphinx-notfound.patch
deleted file mode 100644
index c235dc47..00000000
--- a/debian/patches/0006-remove-sphinx-notfound.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Description: remove sphinx notfound
---- a/docs/docsite/rst/conf.py
-+++ b/docs/docsite/rst/conf.py
-@@ -45,7 +45,7 @@
- # They can be extensions
- # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
- # TEST: 'sphinxcontrib.fulltoc'
--extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx', 'pygments_lexer', 'notfound.extension']
-+extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx', 'pygments_lexer']
-
- # Later on, add 'sphinx.ext.viewcode' to the list if you want to have
- # colorized code generated too for references.
diff --git a/debian/patches/0007-fix-interpreter-fallback.patch b/debian/patches/0007-fix-interpreter-fallback.patch
deleted file mode 100644
index 34a3bd53..00000000
--- a/debian/patches/0007-fix-interpreter-fallback.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Description: Fix python interpreter discovery (Closes: #983140)
- On machines upgrade from buster to bullseye, the wrong interpreter will be
- discovered and used, causing the playbook run to fail. Update the fallback list
- so it correctly picks python3.9 on bullseye when both 3.9 and 3.7 are present,
- which usually is the case on freshly upgrade machines.
-Origin: backport, https://github.com/ansible/ansible/commit/c986cbb9961bfaedf1a6ae7f0c2e34be26d9ab12
-Forwarded: not-needed
-Applied-Upstream: https://github.com/ansible/ansible/commit/c986cbb9961bfaedf1a6ae7f0c2e34be26d9ab12
-Reviewed-by: Lee Garrett <debian@rocketjump.eu>
-Last-Update: 2021-03-23
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/lib/ansible/config/base.yml
-+++ b/lib/ansible/config/base.yml
-@@ -1523,6 +1523,8 @@
- name: Ordered list of Python interpreters to check for in discovery
- default:
- - /usr/bin/python
-+ - python3.9
-+ - python3.8
- - python3.7
- - python3.6
- - python3.5
diff --git a/debian/patches/series b/debian/patches/series
index 34d042cf..4eb268ea 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,2 @@
0003-preserve-debian-dir.patch
0005-use-py3.patch
-0006-remove-sphinx-notfound.patch
-0007-fix-interpreter-fallback.patch