summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTimo Kösters <timo@koesters.xyz>2022-01-21 09:19:19 +0100
committerTimo Kösters <timo@koesters.xyz>2022-01-21 17:54:05 +0100
commitf88523988e23a09ffc5e1b9ab19e435863be3a9a (patch)
tree8c88b0e00d6abef020fb8577bc7be01e6eb09f84 /Cargo.toml
parent4ef995cf7dd13eabc31ef38f59f150f61284befe (diff)
downloadconduit-f88523988e23a09ffc5e1b9ab19e435863be3a9a.zip
improvement: use jemalloc for lower memory usage
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e3614ec..78a4c8f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -48,11 +48,7 @@ rand = "0.8.4"
# Used to hash passwords
rust-argon2 = "0.8.3"
# Used to send requests
-reqwest = { version = "0.11.4", default-features = false, features = ["rustls-tls-native-roots", "socks"] }
-# Custom TLS verifier
-rustls = { version = "0.19.1", features = ["dangerous_configuration"] }
-rustls-native-certs = "0.5.0"
-webpki = "0.22.0"
+reqwest = { version = "0.11.4", default-features = false, features = ["rustls-tls", "socks"] }
# Used for conduit::Error type
thiserror = "1.0.28"
# Used to generate thumbnails for images
@@ -87,6 +83,10 @@ thread_local = "1.1.3"
hmac = "0.11.0"
sha-1 = "0.9.8"
+[target.'cfg(not(target_env = "msvc"))'.dependencies]
+tikv-jemalloc-ctl = { version = "0.4.2", features = ['use_std'] }
+tikv-jemallocator = { version = "0.4.1", features = ['unprefixed_malloc_on_supported_platforms'] }
+
[features]
default = ["conduit_bin", "backend_sqlite", "backend_rocksdb"]
backend_sled = ["sled"]