summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTimo Kösters <timo@koesters.xyz>2022-01-19 07:09:25 +0100
committerTimo Kösters <timo@koesters.xyz>2022-01-19 07:09:25 +0100
commitd4eb3e3295ee1b0947b66d1d45ef10bb4d152839 (patch)
tree016d580ee0b704dd7d79c5fc5d93c55e85d5e9a7 /Cargo.toml
parentb2ffc4e496648537adcddce7c936efef3cd97114 (diff)
downloadconduit-d4eb3e3295ee1b0947b66d1d45ef10bb4d152839.zip
fix: rocksdb does not use zstd compression unless we disable everything else
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 29a090c..3223330 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -78,7 +78,8 @@ crossbeam = { version = "0.8.1", optional = true }
num_cpus = "1.13.0"
threadpool = "1.8.1"
heed = { git = "https://github.com/timokoesters/heed.git", rev = "f6f825da7fb2c758867e05ad973ef800a6fe1d5d", optional = true }
-rocksdb = { version = "0.17.0", features = ["multi-threaded-cf"], optional = true }
+rocksdb = { version = "0.17.0", default-features = false, features = ["multi-threaded-cf", "zstd"], optional = true }
+
thread_local = "1.1.3"
# used for TURN server authentication
hmac = "0.11.0"