summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJonas Platte <jplatte+git@posteo.de>2022-01-22 18:38:39 +0100
committerJonas Platte <jplatte+git@posteo.de>2022-02-12 12:56:08 +0100
commitc8951a1d9cc05a8c138be06f520a78b4cbb053c7 (patch)
tree8aab4bb1949a28983ce3ee971fd6215ee0403098 /Cargo.toml
parent5fa9190117805ff1040c69b65a3b9caacb6c965b (diff)
downloadconduit-c8951a1d9cc05a8c138be06f520a78b4cbb053c7.zip
Use axum-server for direct TLS support
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5fb75dc..6dedfa8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ edition = "2021"
[dependencies]
# Web framework
axum = { version = "0.4.4", features = ["headers"], optional = true }
-hyper = "0.14.16"
+axum-server = { version = "0.3.3", features = ["tls-rustls"] }
tower = { version = "0.4.11", features = ["util"] }
tower-http = { version = "0.2.1", features = ["add-extension", "cors", "compression-full", "sensitive-headers", "trace", "util"] }