summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTimo Kösters <timo@koesters.xyz>2022-02-04 11:27:41 +0000
committerTimo Kösters <timo@koesters.xyz>2022-02-04 11:27:41 +0000
commit8db7d2c025c4a5dbc46dec306ef019303da813f6 (patch)
treee114ad30c575df145eb5cdc072dbd64d46e46702 /Cargo.toml
parent51cca1a60ff6ea002ef5ca591cd9aeb25d071325 (diff)
parentb39ddf7be9150b8baa6cecabed7730d2ab610a72 (diff)
downloadconduit-8db7d2c025c4a5dbc46dec306ef019303da813f6.zip
Merge branch 'asonix/encourage-reqwest-reuse' into 'next'
Re-use a basic reqwest client in all possible cases See merge request famedly/conduit!265
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1e1b188..aac840b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -48,7 +48,7 @@ rand = "0.8.4"
# Used to hash passwords
rust-argon2 = "0.8.3"
# Used to send requests
-reqwest = { version = "0.11.4", default-features = false, features = ["rustls-tls", "socks"] }
+reqwest = { version = "0.11.4", default-features = false, features = ["rustls-tls", "socks"], git = "https://github.com/niuhuan/reqwest", branch = "dns-resolver-fn" }
# Used for conduit::Error type
thiserror = "1.0.28"
# Used to generate thumbnails for images