summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTimo Kösters <timo@koesters.xyz>2022-02-04 16:59:30 +0100
committerTimo Kösters <timo@koesters.xyz>2022-02-04 17:00:46 +0100
commit8d8edddb2e1074bf36a14b244c7ed9a0eec054dc (patch)
treec77f0276b19c3df4a828cde026c3962048742240 /Cargo.toml
parentf35ad276279b15458af1bb27aead220d19968b96 (diff)
downloadconduit-8d8edddb2e1074bf36a14b244c7ed9a0eec054dc.zip
feat: allow disabling jemalloc via feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aac840b..dd31c84 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -86,17 +86,17 @@ sha-1 = "0.9.8"
clap = { version = "3.0.10", default-features = false, features = ["std", "derive"] }
maplit = "1.0.2"
-[target.'cfg(not(target_env = "msvc"))'.dependencies]
-tikv-jemalloc-ctl = { version = "0.4.2", features = ['use_std'] }
-tikv-jemallocator = { version = "0.4.1", features = ['unprefixed_malloc_on_supported_platforms'] }
+tikv-jemalloc-ctl = { version = "0.4.2", features = ["use_std"], optional = true }
+tikv-jemallocator = { version = "0.4.1", features = ["unprefixed_malloc_on_supported_platforms"], optional = true }
[features]
-default = ["conduit_bin", "backend_sqlite", "backend_rocksdb"]
+default = ["conduit_bin", "backend_sqlite", "backend_rocksdb", "jemalloc"]
backend_sled = ["sled"]
backend_persy = ["persy", "parking_lot"]
backend_sqlite = ["sqlite"]
backend_heed = ["heed", "crossbeam"]
backend_rocksdb = ["rocksdb"]
+jemalloc = ["tikv-jemalloc-ctl", "tikv-jemallocator"]
sqlite = ["rusqlite", "parking_lot", "tokio/signal"]
conduit_bin = [] # TODO: add rocket to this when it is optional