summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrei Vasiliu <whyte.vuhuni@gmail.com>2022-01-22 14:29:50 +0200
committerAndrei Vasiliu <whyte.vuhuni@gmail.com>2022-01-22 14:29:50 +0200
commit7505548b946503879e164b184d361c5af015c18c (patch)
treedf4effa85f04e50f1903a145358d3fa6313d81af /Cargo.toml
parent57979da28c0af4bc14787575d94308d5762e7dc6 (diff)
parentf50bdb6010292bf8cb5677d6fead89764b25e9a6 (diff)
downloadconduit-7505548b946503879e164b184d361c5af015c18c.zip
Merge remote-tracking branch 'refs/remotes/origin/next' into command-refactor
Resolved conflict for the new list_local_users command
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3f8677d..89788fa 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,6 +29,7 @@ tokio = "1.11.0"
# Used for storing data permanently
sled = { version = "0.34.6", features = ["compression", "no_metrics"], optional = true }
#sled = { git = "https://github.com/spacejam/sled.git", rev = "e4640e0773595229f398438886f19bca6f7326a2", features = ["compression"] }
+persy = { version = "1.2" , optional = true, features=["background_ops"] }
# Used for the http request / response body type for Ruma endpoints used with reqwest
bytes = "1.1.0"
@@ -47,11 +48,7 @@ rand = "0.8.4"
# Used to hash passwords
rust-argon2 = "0.8.3"
# Used to send requests
-reqwest = { version = "0.11.4", default-features = false, features = ["rustls-tls-native-roots", "socks"] }
-# Custom TLS verifier
-rustls = { version = "0.19.1", features = ["dangerous_configuration"] }
-rustls-native-certs = "0.5.0"
-webpki = "0.22.0"
+reqwest = { version = "0.11.4", default-features = false, features = ["rustls-tls", "socks"] }
# Used for conduit::Error type
thiserror = "1.0.28"
# Used to generate thumbnails for images
@@ -88,9 +85,14 @@ sha-1 = "0.9.8"
# used for conduit's CLI and admin room command parsing
clap = { version = "3.0.10", default-features = false, features = ["std", "derive"] }
+[target.'cfg(not(target_env = "msvc"))'.dependencies]
+tikv-jemalloc-ctl = { version = "0.4.2", features = ['use_std'] }
+tikv-jemallocator = { version = "0.4.1", features = ['unprefixed_malloc_on_supported_platforms'] }
+
[features]
default = ["conduit_bin", "backend_sqlite", "backend_rocksdb"]
backend_sled = ["sled"]
+backend_persy = ["persy", "parking_lot"]
backend_sqlite = ["sqlite"]
backend_heed = ["heed", "crossbeam"]
backend_rocksdb = ["rocksdb"]