summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVladan Popovic <vladanovic@gmail.com>2022-11-25 21:20:45 +0100
committerVladan Popovic <vladanovic@gmail.com>2022-11-27 22:17:15 +0100
commit66ad114e1909ddde5a17005df9c332605a9f9d60 (patch)
treee5723d26907c61e6d721f39c78437642de651bb1 /Cargo.toml
parent4b737b46acfe7cbfcbe293d6262b5c1b7c64dcb6 (diff)
downloadconduit-66ad114e1909ddde5a17005df9c332605a9f9d60.zip
feat: add systemd feature flag
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ae51945..801d363 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -93,8 +93,10 @@ tikv-jemallocator = { version = "0.5.0", features = ["unprefixed_malloc_on_suppo
lazy_static = "1.4.0"
async-trait = "0.1.57"
+sd-notify = { version = "0.4.1", optional = true }
+
[features]
-default = ["conduit_bin", "backend_sqlite", "backend_rocksdb", "jemalloc"]
+default = ["conduit_bin", "backend_sqlite", "backend_rocksdb", "jemalloc", "systemd"]
#backend_sled = ["sled"]
backend_persy = ["persy", "parking_lot"]
backend_sqlite = ["sqlite"]
@@ -103,6 +105,7 @@ backend_rocksdb = ["rocksdb"]
jemalloc = ["tikv-jemalloc-ctl", "tikv-jemallocator"]
sqlite = ["rusqlite", "parking_lot", "tokio/signal"]
conduit_bin = ["axum"]
+systemd = ["sd-notify"]
[[bin]]
name = "conduit"