summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTimo Kösters <timo@koesters.xyz>2022-01-21 15:31:46 +0000
committerTimo Kösters <timo@koesters.xyz>2022-01-21 15:31:46 +0000
commit5d3ba5c62821f92dd3593d04912a4a21067ae34e (patch)
treeb8e2b56a073ede74406852561b1ccc2ef08add9c /Cargo.toml
parentab4f3bd06c778e58a7e44935d3b878ee1249bc30 (diff)
parentc1cd4b5e26c68d1c5e91f85df2a65591f774d13c (diff)
downloadconduit-5d3ba5c62821f92dd3593d04912a4a21067ae34e.zip
Merge branch 'WIP_persy_batch_next' into 'next'
feat: Integration with persy using background ops See merge request famedly/conduit!231
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f335873..e3614ec 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,6 +29,7 @@ tokio = "1.11.0"
# Used for storing data permanently
sled = { version = "0.34.6", features = ["compression", "no_metrics"], optional = true }
#sled = { git = "https://github.com/spacejam/sled.git", rev = "e4640e0773595229f398438886f19bca6f7326a2", features = ["compression"] }
+persy = { version = "1.2" , optional = true, features=["background_ops"] }
# Used for the http request / response body type for Ruma endpoints used with reqwest
bytes = "1.1.0"
@@ -89,6 +90,7 @@ sha-1 = "0.9.8"
[features]
default = ["conduit_bin", "backend_sqlite", "backend_rocksdb"]
backend_sled = ["sled"]
+backend_persy = ["persy", "parking_lot"]
backend_sqlite = ["sqlite"]
backend_heed = ["heed", "crossbeam"]
backend_rocksdb = ["rocksdb"]