summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCharles Hall <charles@computer.surgery>2022-10-12 17:48:09 -0700
committerCharles Hall <charles@computer.surgery>2022-10-12 17:55:12 -0700
commit4710f739c0b9b230a155ffb2cf0947d96a4246cc (patch)
tree1e22f19ea37f54bba01e5e904e062bcdbb8a08a2 /Cargo.toml
parent3c20c1b72e8aef3253ad1c96e8943b9803bb0a3b (diff)
downloadconduit-4710f739c0b9b230a155ffb2cf0947d96a4246cc.zip
clap v4 turned more things into optional features
So we need to re-enable some things. See their changelog[0] for details. [0]: https://github.com/clap-rs/clap/blob/master/CHANGELOG.md#migrating
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cce6f9b..e7e48c8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -83,7 +83,7 @@ thread_local = "1.1.3"
hmac = "0.12.1"
sha-1 = "0.10.0"
# used for conduit's CLI and admin room command parsing
-clap = { version = "4.0.11", default-features = false, features = ["std", "derive"] }
+clap = { version = "4.0.11", default-features = false, features = ["std", "derive", "help", "usage", "error-context"] }
futures-util = { version = "0.3.17", default-features = false }
# Used for reading the configuration from conduit.toml & environment variables
figment = { version = "0.10.6", features = ["env", "toml"] }