summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTglman <tglman@tglman.com>2021-12-23 22:59:17 +0000
committerTglman <tglman@tglman.com>2022-01-15 14:17:15 +0000
commit1cc41937bd9ae7679aa48c10074ac1041d3a94b5 (patch)
tree17b9509f650e961f5e1785ae3a382f734f85a41f /Cargo.toml
parentab15ec6c32f2e5463369fe7a29f5ea2e6d9c4f2d (diff)
downloadconduit-1cc41937bd9ae7679aa48c10074ac1041d3a94b5.zip
refactor:use generic watcher in persy implementation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2dbd3fd..7c94a69 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,9 +29,6 @@ tokio = "1.11.0"
sled = { version = "0.34.6", features = ["compression", "no_metrics"], optional = true }
#sled = { git = "https://github.com/spacejam/sled.git", rev = "e4640e0773595229f398438886f19bca6f7326a2", features = ["compression"] }
persy = { git = "https://gitlab.com/tglman/persy.git", branch="master" , optional = true, features=["background_ops"] }
-# Used by the persy write cache for background flush
-timer = "0.2"
-chrono = "0.4"
# Used for the http request / response body type for Ruma endpoints used with reqwest
bytes = "1.1.0"
@@ -91,7 +88,7 @@ sha-1 = "0.9.8"
[features]
default = ["conduit_bin", "backend_sqlite", "backend_rocksdb"]
backend_sled = ["sled"]
-backend_persy = ["persy"]
+backend_persy = ["persy", "parking_lot"]
backend_sqlite = ["sqlite"]
backend_heed = ["heed", "crossbeam"]
backend_rocksdb = ["rocksdb"]