summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTimo Kösters <timo@koesters.xyz>2023-06-25 23:43:19 +0200
committerTimo Kösters <timo@koesters.xyz>2023-06-25 23:43:54 +0200
commit15cc801840465ec5bfd309deecd09b484dd27734 (patch)
tree6d56e39df7403a482f4345720aad3d533dffb647 /Cargo.toml
parent5f9ca8e458982598d26e5d64442f46ac44662f27 (diff)
downloadconduit-15cc801840465ec5bfd309deecd09b484dd27734.zip
Disable compression, see https://en.wikipedia.org/wiki/BREACH
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 12e9109..6055563 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,7 +22,7 @@ rust-version = "1.64.0"
axum = { version = "0.5.16", default-features = false, features = ["form", "headers", "http1", "http2", "json", "matched-path"], optional = true }
axum-server = { version = "0.5.1", features = ["tls-rustls"] }
tower = { version = "0.4.13", features = ["util"] }
-tower-http = { version = "0.4.1", features = ["add-extension", "cors", "compression-zstd", "sensitive-headers", "trace", "util"] }
+tower-http = { version = "0.4.1", features = ["add-extension", "cors", "sensitive-headers", "trace", "util"] }
# Used for matrix spec type definitions and helpers
#ruma = { version = "0.4.0", features = ["compat", "rand", "appservice-api-c", "client-api", "federation-api", "push-gateway-api-c", "state-res", "unstable-pre-spec", "unstable-exhaustive-types"] }