summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0d097c1..dbd6bd6 100644
--- a/setup.py
+++ b/setup.py
@@ -29,12 +29,19 @@ setup(
"Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
],
scripts=['calendar-cli.py', 'calendar-cli'],
+ py_modules=['cal'],
install_requires=[
'icalendar',
'caldav>=0.8.1',
'pytz', ## pytz is supposed to be obsoleted, but see https://github.com/collective/icalendar/issues/333
'tzlocal',
+ 'Click',
'six'
],
+ entry_points={
+ 'console_scripts': [
+ 'kal = cal:cli',
+ ],
+ },
**metadata
)