# Contributor: Adam Thiede <me@adamthiede.com>
# Maintainer: Adam Thiede <me@adamthiede.com>
pkgname=reader
pkgver=0.4.5
pkgrel=0
pkgdesc="reader parses a web page for its actual content and displays it in nicely highlighted text on the command line."
url="https://github.com/mrusme/reader"
# loongarch64: fail to build utls
arch="all !loongarch64"
license="GPL-3.0-only"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/mrusme/reader/archive/v$pkgver.tar.gz"
options="!check" # no tests

export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"

build() {
	go build
}

package() {
	install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
}

sha512sums="
09bdc7c769499f92c50a0754006af72a0739a228732fe6728fb1d14495a2ce5fe6ac06f5d7158da12ceed8c0c229a4e43185c0b8d45e5cd07c0ace2ab13d96d1  reader-0.4.5.tar.gz
"