# Contributor: David Demelier <markand@malikania.fr>
# Maintainer: David Demelier <markand@malikania.fr>
pkgname=aubio
pkgver=0.4.9
pkgrel=4
pkgdesc="tool designed for the extraction of annotations from audio signals"
url="https://aubio.org"
arch="all"
license="GPL-3.0-or-later"
makedepends="
	ffmpeg-dev
	fftw-dev
	jack-dev
	libsamplerate-dev
	libsndfile-dev
	python3
	waf
	"
subpackages="$pkgname-static $pkgname-dev"
source="https://aubio.org/pub/aubio-$pkgver.tar.bz2
	unversioned-python.patch
	waf-2.1.0-compat.patch
	$pkgname-ffmpeg5.patch::https://github.com/aubio/aubio/commit/8a05420e5dd8c7b8b2447f82dc919765876511b3.patch
	"

prepare() {
	default_prepare

	rm -rf waf waflib
	ln -s /usr/bin/waf waf
}

build() {
	python3 waf configure --prefix=/usr
	python3 waf build
}

check() {
	# The waf file does not have a check target but the tests are run during the
	# build() function
	:
}

package() {
	python3 waf install --destdir="$pkgdir" --notests
}

sha512sums="
0cb81bb4b15051db3f3f4d160d500af56fdfb237e0a74e3f366f53c2870030aa0a7cee8469a611a9694c36b8866d3d42ffb48241c999de08f3fee43e6d903130  aubio-0.4.9.tar.bz2
08ef8497caec4a6025bfada1e7718469943f71e1847d2b340731483d6b396da7d367b1a180f87d70590109bfe2e7bd74141aebc458c607f5f96fd42e618e7ea7  unversioned-python.patch
10a19f724740de1bbae3c1dcb08f0046b9096673111c2f1a3f98ec32a6b64db20040a4048bd668307cba5cb946f6385158cb34f1279a4b30bd09b5cb6e8ec8f0  waf-2.1.0-compat.patch
8ce2a1fc35f73586d92e637d76354843c8cd1bdd5cda2b8e56db6b05ddcea4d2297500f9039f53d9482bff68fc1ee9e60c9459799a900e85f373745b3258b7ef  aubio-ffmpeg5.patch
"