summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/cdogs-sdl/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/cdogs-sdl/APKBUILD b/testing/cdogs-sdl/APKBUILD
new file mode 100644
index 00000000000..c005f7577b7
--- /dev/null
+++ b/testing/cdogs-sdl/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Díaz Urbaneja Diego <sodomon2@gmail.com>
+# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
+pkgname=cdogs-sdl
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="Classic overhead run-and-gun game"
+url="https://cxong.github.io/cdogs-sdl/"
+arch="x86_64 x86"
+license="GPL"
+depends="sdl2 sdl2_mixer sdl2_image mesa"
+makedepends="cmake"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cxong/$pkgname/archive/$pkgver.tar.gz"
+
+build() {
+ cmake CMakeLists.txt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCDOGS_DATA_DIR=/usr/share/cdogs-sdl/ \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="33ff3a0fa9c8f5d32b79caf52fc9cf1472d71245821f841fdaa926acaa7c4342884be975962f128e5d5f24e2ad86923547116f8ca29d157960cc1181d4aa6cba cdogs-sdl-0.7.0.tar.gz"