summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/a2jmidid/APKBUILD2
-rw-r--r--testing/apostrophe/APKBUILD2
-rw-r--r--testing/confy/APKBUILD2
-rw-r--r--testing/curtail/APKBUILD2
-rw-r--r--testing/dosbox-staging/APKBUILD2
-rw-r--r--testing/drawing/APKBUILD2
-rw-r--r--testing/efl/APKBUILD2
-rw-r--r--testing/eolie/APKBUILD2
-rw-r--r--testing/espeakup/APKBUILD2
-rw-r--r--testing/fastd/APKBUILD2
-rw-r--r--testing/findtow/APKBUILD2
-rw-r--r--testing/gdm-settings/APKBUILD2
-rw-r--r--testing/getting-things-gnome/APKBUILD2
-rw-r--r--testing/gnome-metronome/APKBUILD2
-rw-r--r--testing/gst-rtsp-server/APKBUILD2
-rw-r--r--testing/helvum/APKBUILD2
-rw-r--r--testing/himitsu-keyring/APKBUILD2
-rw-r--r--testing/hiprompt-gtk-py/APKBUILD2
-rw-r--r--testing/igt-gpu-tools/APKBUILD2
-rw-r--r--testing/imrsh/APKBUILD2
-rw-r--r--testing/khronos/APKBUILD2
-rw-r--r--testing/lapel/APKBUILD2
-rw-r--r--testing/libui/APKBUILD2
-rw-r--r--testing/libva-utils/APKBUILD2
-rw-r--r--testing/lite-xl/APKBUILD2
-rw-r--r--testing/materia-gtk-theme/APKBUILD2
-rw-r--r--testing/miraclecast/APKBUILD2
-rw-r--r--testing/moka-icon-theme/APKBUILD2
-rw-r--r--testing/mrsh/APKBUILD2
-rw-r--r--testing/objconv/APKBUILD2
-rw-r--r--testing/paprefs/APKBUILD2
-rw-r--r--testing/pinephone-compass/APKBUILD2
-rw-r--r--testing/piper/APKBUILD2
-rw-r--r--testing/pithos/APKBUILD2
-rw-r--r--testing/powder-toy/APKBUILD2
-rw-r--r--testing/power-profiles-daemon/APKBUILD2
-rw-r--r--testing/powersupply/APKBUILD2
-rw-r--r--testing/py3-pyatem/APKBUILD4
-rw-r--r--testing/ratbag/APKBUILD2
-rwxr-xr-xtesting/read-it-later/APKBUILD2
-rw-r--r--testing/rizin/APKBUILD2
-rw-r--r--testing/rkdeveloptool/APKBUILD2
-rw-r--r--testing/rnote/APKBUILD2
-rw-r--r--testing/sane-airscan/APKBUILD2
-rw-r--r--testing/shipments/APKBUILD2
-rw-r--r--testing/slurm/APKBUILD2
-rw-r--r--testing/solanum/APKBUILD2
-rw-r--r--testing/swappy/APKBUILD2
-rw-r--r--testing/tang/APKBUILD2
-rw-r--r--testing/tangram/APKBUILD2
-rw-r--r--testing/termbox/APKBUILD2
-rw-r--r--testing/thumbdrives/APKBUILD2
-rw-r--r--testing/uasm/APKBUILD2
-rw-r--r--testing/viewnior/APKBUILD2
-rw-r--r--testing/wbg/APKBUILD2
-rw-r--r--testing/wcm/APKBUILD2
-rw-r--r--testing/wf-config/APKBUILD2
-rw-r--r--testing/wf-osk/APKBUILD2
-rw-r--r--testing/wiremapper/APKBUILD2
-rw-r--r--testing/wlavu/APKBUILD2
-rw-r--r--testing/wlclock/APKBUILD2
-rw-r--r--testing/wlrobs/APKBUILD2
-rw-r--r--testing/wlroots0.12/APKBUILD2
-rw-r--r--testing/wlroots0.15/APKBUILD2
-rw-r--r--testing/wlvncc/APKBUILD2
-rw-r--r--testing/wmenu/APKBUILD2
-rw-r--r--testing/wshowkeys/APKBUILD2
-rw-r--r--testing/zathura-djvu/APKBUILD2
68 files changed, 69 insertions, 69 deletions
diff --git a/testing/a2jmidid/APKBUILD b/testing/a2jmidid/APKBUILD
index 7d540a52a09..37af43e5496 100644
--- a/testing/a2jmidid/APKBUILD
+++ b/testing/a2jmidid/APKBUILD
@@ -17,7 +17,7 @@ options="!check" # No testsuite
build() {
abuild-meson . build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
diff --git a/testing/apostrophe/APKBUILD b/testing/apostrophe/APKBUILD
index 1505c1e04e9..e1bce9d6f99 100644
--- a/testing/apostrophe/APKBUILD
+++ b/testing/apostrophe/APKBUILD
@@ -41,7 +41,7 @@ prepare() {
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/confy/APKBUILD b/testing/confy/APKBUILD
index 9b29a4c6514..ecf12141cb8 100644
--- a/testing/confy/APKBUILD
+++ b/testing/confy/APKBUILD
@@ -25,7 +25,7 @@ subpackages="$pkgname-lang"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/curtail/APKBUILD b/testing/curtail/APKBUILD
index ee77f8101d7..ae06f0ed347 100644
--- a/testing/curtail/APKBUILD
+++ b/testing/curtail/APKBUILD
@@ -30,7 +30,7 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
abuild-meson . build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
diff --git a/testing/dosbox-staging/APKBUILD b/testing/dosbox-staging/APKBUILD
index 82fcfe99d2d..5226580877b 100644
--- a/testing/dosbox-staging/APKBUILD
+++ b/testing/dosbox-staging/APKBUILD
@@ -36,7 +36,7 @@ build() {
-Duse_mt32emu=false \
-Ddefault_library=shared \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/drawing/APKBUILD b/testing/drawing/APKBUILD
index c47862fdede..63cae6693f7 100644
--- a/testing/drawing/APKBUILD
+++ b/testing/drawing/APKBUILD
@@ -27,7 +27,7 @@ subpackages="$pkgname-lang"
build() {
abuild-meson . build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
diff --git a/testing/efl/APKBUILD b/testing/efl/APKBUILD
index de190c6e59b..5d9c4abc75a 100644
--- a/testing/efl/APKBUILD
+++ b/testing/efl/APKBUILD
@@ -73,7 +73,7 @@ build() {
-Decore-imf-loaders-disabler=ibus,scim \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
diff --git a/testing/eolie/APKBUILD b/testing/eolie/APKBUILD
index d674e6afd23..85fe3f46b29 100644
--- a/testing/eolie/APKBUILD
+++ b/testing/eolie/APKBUILD
@@ -36,7 +36,7 @@ prepare() {
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/espeakup/APKBUILD b/testing/espeakup/APKBUILD
index 88666983f5a..729812cf409 100644
--- a/testing/espeakup/APKBUILD
+++ b/testing/espeakup/APKBUILD
@@ -17,7 +17,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/linux-speakup/espeakup/archi
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/fastd/APKBUILD b/testing/fastd/APKBUILD
index 8ef577854c4..3cab239f039 100644
--- a/testing/fastd/APKBUILD
+++ b/testing/fastd/APKBUILD
@@ -23,7 +23,7 @@ build() {
-Dsystemd=disabled \
-Dbuild_tests="$(options_has !check && echo false || echo true)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/findtow/APKBUILD b/testing/findtow/APKBUILD
index c9e5de20e57..83ae32cca56 100644
--- a/testing/findtow/APKBUILD
+++ b/testing/findtow/APKBUILD
@@ -13,7 +13,7 @@ options="!check" # No testsuite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/gdm-settings/APKBUILD b/testing/gdm-settings/APKBUILD
index eb7d2211fb4..9a075bb5974 100644
--- a/testing/gdm-settings/APKBUILD
+++ b/testing/gdm-settings/APKBUILD
@@ -28,7 +28,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/realmazharhussain/gdm-settin
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/getting-things-gnome/APKBUILD b/testing/getting-things-gnome/APKBUILD
index e44678acb04..5d170755392 100644
--- a/testing/getting-things-gnome/APKBUILD
+++ b/testing/getting-things-gnome/APKBUILD
@@ -16,7 +16,7 @@ builddir="$srcdir/gtg-$pkgver"
build() {
abuild-meson output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/gnome-metronome/APKBUILD b/testing/gnome-metronome/APKBUILD
index d9aed6f4736..3a6c832b5c5 100644
--- a/testing/gnome-metronome/APKBUILD
+++ b/testing/gnome-metronome/APKBUILD
@@ -27,7 +27,7 @@ builddir="$srcdir/metronome-$pkgver"
build() {
abuild-meson build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
diff --git a/testing/gst-rtsp-server/APKBUILD b/testing/gst-rtsp-server/APKBUILD
index 5cda02a031f..cb5d517eca4 100644
--- a/testing/gst-rtsp-server/APKBUILD
+++ b/testing/gst-rtsp-server/APKBUILD
@@ -30,7 +30,7 @@ build() {
-Dpackage-name="GStreamer RTSP server (Alpine Linux)" \
-Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/helvum/APKBUILD b/testing/helvum/APKBUILD
index 0c5977bbe16..9863c786805 100644
--- a/testing/helvum/APKBUILD
+++ b/testing/helvum/APKBUILD
@@ -15,7 +15,7 @@ options="!check" # no test suite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/himitsu-keyring/APKBUILD b/testing/himitsu-keyring/APKBUILD
index 82416e00047..b7e5ac9b267 100644
--- a/testing/himitsu-keyring/APKBUILD
+++ b/testing/himitsu-keyring/APKBUILD
@@ -13,7 +13,7 @@ builddir="$srcdir/keyring-$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/hiprompt-gtk-py/APKBUILD b/testing/hiprompt-gtk-py/APKBUILD
index 925b9a2ac4b..6a7befb5f33 100644
--- a/testing/hiprompt-gtk-py/APKBUILD
+++ b/testing/hiprompt-gtk-py/APKBUILD
@@ -14,7 +14,7 @@ builddir="$srcdir/$pkgname-$_commit"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/igt-gpu-tools/APKBUILD b/testing/igt-gpu-tools/APKBUILD
index d15b6345989..69841caf8a3 100644
--- a/testing/igt-gpu-tools/APKBUILD
+++ b/testing/igt-gpu-tools/APKBUILD
@@ -44,7 +44,7 @@ build() {
-Dvalgrind=disabled \
-Dversion_hash=$pkgver \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
diff --git a/testing/imrsh/APKBUILD b/testing/imrsh/APKBUILD
index 84698d2b9ca..26c0547c6ba 100644
--- a/testing/imrsh/APKBUILD
+++ b/testing/imrsh/APKBUILD
@@ -17,7 +17,7 @@ options="!check" # no test suite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/khronos/APKBUILD b/testing/khronos/APKBUILD
index 8ea37fb6c3b..734d9623bd8 100644
--- a/testing/khronos/APKBUILD
+++ b/testing/khronos/APKBUILD
@@ -22,7 +22,7 @@ source="https://github.com/lainsce/khronos/archive/refs/tags/$pkgver/khronos-$pk
build() {
abuild-meson \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/lapel/APKBUILD b/testing/lapel/APKBUILD
index 6c7a87eae53..7e9eb43a1d6 100644
--- a/testing/lapel/APKBUILD
+++ b/testing/lapel/APKBUILD
@@ -23,7 +23,7 @@ options="!check" # no test suite
build() {
abuild-meson \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/libui/APKBUILD b/testing/libui/APKBUILD
index df6b4635261..baa17f9e8b7 100644
--- a/testing/libui/APKBUILD
+++ b/testing/libui/APKBUILD
@@ -20,7 +20,7 @@ build() {
pwd
echo $builddir
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/libva-utils/APKBUILD b/testing/libva-utils/APKBUILD
index 02a37a24590..bc934f3288e 100644
--- a/testing/libva-utils/APKBUILD
+++ b/testing/libva-utils/APKBUILD
@@ -25,7 +25,7 @@ build() {
-Dwayland=true \
-Dtests=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/lite-xl/APKBUILD b/testing/lite-xl/APKBUILD
index dde4a3a9367..06e34f2a1cc 100644
--- a/testing/lite-xl/APKBUILD
+++ b/testing/lite-xl/APKBUILD
@@ -22,7 +22,7 @@ options="!check" # no tests available
build() {
abuild-meson -Darch_tuple="$CARCH-linux" . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/materia-gtk-theme/APKBUILD b/testing/materia-gtk-theme/APKBUILD
index 1465def2750..f6e39890ade 100644
--- a/testing/materia-gtk-theme/APKBUILD
+++ b/testing/materia-gtk-theme/APKBUILD
@@ -42,7 +42,7 @@ build() {
abuild-meson \
-Dgnome_shell_version=3.38 \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/miraclecast/APKBUILD b/testing/miraclecast/APKBUILD
index 6939e890ca3..1d2b8ff934b 100644
--- a/testing/miraclecast/APKBUILD
+++ b/testing/miraclecast/APKBUILD
@@ -25,7 +25,7 @@ build() {
. output \
-Denable-systemd=false \
-Dbuild-tests=true
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/moka-icon-theme/APKBUILD b/testing/moka-icon-theme/APKBUILD
index de24aedf6f4..8583740dede 100644
--- a/testing/moka-icon-theme/APKBUILD
+++ b/testing/moka-icon-theme/APKBUILD
@@ -13,7 +13,7 @@ source="moka-icon-theme-$pkgver.tar.gz::https://github.com/snwh/moka-icon-theme/
build() {
abuild-meson output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/mrsh/APKBUILD b/testing/mrsh/APKBUILD
index c80ba876b6e..62339f64c71 100644
--- a/testing/mrsh/APKBUILD
+++ b/testing/mrsh/APKBUILD
@@ -16,7 +16,7 @@ builddir="$srcdir/mrsh-$_commit"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/objconv/APKBUILD b/testing/objconv/APKBUILD
index 9e6452fac19..4a253da43cb 100644
--- a/testing/objconv/APKBUILD
+++ b/testing/objconv/APKBUILD
@@ -22,7 +22,7 @@ prepare() {
build() {
cd "${builddir}/src/"
- make ${JOBS:+-j ${JOBS}} -f "../Makefile"
+ make -f "../Makefile"
}
package() {
diff --git a/testing/paprefs/APKBUILD b/testing/paprefs/APKBUILD
index 5231e0712bb..8a820329d3c 100644
--- a/testing/paprefs/APKBUILD
+++ b/testing/paprefs/APKBUILD
@@ -19,7 +19,7 @@ source="https://freedesktop.org/software/pulseaudio/paprefs/paprefs-$pkgver.tar.
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/pinephone-compass/APKBUILD b/testing/pinephone-compass/APKBUILD
index af3b96f7bfd..b11ba48a2ed 100644
--- a/testing/pinephone-compass/APKBUILD
+++ b/testing/pinephone-compass/APKBUILD
@@ -17,7 +17,7 @@ builddir="$srcdir/$pkgname-v$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/piper/APKBUILD b/testing/piper/APKBUILD
index c19940451a6..b9287b6d01c 100644
--- a/testing/piper/APKBUILD
+++ b/testing/piper/APKBUILD
@@ -18,7 +18,7 @@ build() {
-Druntime-dependency-checks=false \
-Dtests="$(want_check && echo true || echo false)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/pithos/APKBUILD b/testing/pithos/APKBUILD
index 4aafb7ade80..4df28f16c64 100644
--- a/testing/pithos/APKBUILD
+++ b/testing/pithos/APKBUILD
@@ -27,7 +27,7 @@ source="https://github.com/pithos/pithos/releases/download/$pkgver/pithos-$pkgve
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/powder-toy/APKBUILD b/testing/powder-toy/APKBUILD
index d1ef4debeca..5ded4fd3f74 100644
--- a/testing/powder-toy/APKBUILD
+++ b/testing/powder-toy/APKBUILD
@@ -30,7 +30,7 @@ build() {
abuild-meson \
-Db_lto=true \
. build
- meson compile -v ${JOBS:+-j ${JOBS}} -C build
+ meson compile -v -C build
}
package() {
diff --git a/testing/power-profiles-daemon/APKBUILD b/testing/power-profiles-daemon/APKBUILD
index a106c7361c6..43f3bd0aa15 100644
--- a/testing/power-profiles-daemon/APKBUILD
+++ b/testing/power-profiles-daemon/APKBUILD
@@ -28,7 +28,7 @@ build() {
-Dsystemdsystemunitdir="" \
-Dtests="$(want_check && echo true || echo false)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/powersupply/APKBUILD b/testing/powersupply/APKBUILD
index 6312b827ea6..818c2d3e835 100644
--- a/testing/powersupply/APKBUILD
+++ b/testing/powersupply/APKBUILD
@@ -21,7 +21,7 @@ options="!check" # There's no testsuite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/py3-pyatem/APKBUILD b/testing/py3-pyatem/APKBUILD
index 2f21c2f3d0b..4be23149423 100644
--- a/testing/py3-pyatem/APKBUILD
+++ b/testing/py3-pyatem/APKBUILD
@@ -26,11 +26,11 @@ build() {
# Build the GTK app
abuild-meson -Dwith_proxy=False . output_gtk
- meson compile ${JOBS:+-j ${JOBS}} -C output_gtk
+ meson compile -C output_gtk
# Build the proxy daemon
abuild-meson -Dwith_gtk_app=False . output_proxy
- meson compile ${JOBS:+-j ${JOBS}} -C output_proxy
+ meson compile -C output_proxy
}
check() {
diff --git a/testing/ratbag/APKBUILD b/testing/ratbag/APKBUILD
index e9bba714fbf..ae3c9abd2b1 100644
--- a/testing/ratbag/APKBUILD
+++ b/testing/ratbag/APKBUILD
@@ -32,7 +32,7 @@ build() {
-Dlogind-provider=elogind \
-Dtests="$(want_check && echo true || echo false)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/read-it-later/APKBUILD b/testing/read-it-later/APKBUILD
index d404024efa9..dc659871df5 100755
--- a/testing/read-it-later/APKBUILD
+++ b/testing/read-it-later/APKBUILD
@@ -21,7 +21,7 @@ options="!check" # no tests
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/rizin/APKBUILD b/testing/rizin/APKBUILD
index 067317ddffa..75b7673116e 100644
--- a/testing/rizin/APKBUILD
+++ b/testing/rizin/APKBUILD
@@ -59,7 +59,7 @@ build() {
-Duse_sys_openssl=enabled \
-Duse_sys_tree_sitter=enabled \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/rkdeveloptool/APKBUILD b/testing/rkdeveloptool/APKBUILD
index 536485b4a69..adfb769c14c 100644
--- a/testing/rkdeveloptool/APKBUILD
+++ b/testing/rkdeveloptool/APKBUILD
@@ -13,7 +13,7 @@ options="!check" # There is no testsuite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/rnote/APKBUILD b/testing/rnote/APKBUILD
index 1dadc4c6ab8..63c281f7c85 100644
--- a/testing/rnote/APKBUILD
+++ b/testing/rnote/APKBUILD
@@ -35,7 +35,7 @@ export CARGO_PROFILE_RELEASE_LTO=thin
build() {
abuild-meson \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
meson test --no-rebuild --print-errorlogs -C output
diff --git a/testing/sane-airscan/APKBUILD b/testing/sane-airscan/APKBUILD
index fb0c6d697d7..e9563c85ce9 100644
--- a/testing/sane-airscan/APKBUILD
+++ b/testing/sane-airscan/APKBUILD
@@ -23,7 +23,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/alexpevzner/sane-airscan/arc
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/shipments/APKBUILD b/testing/shipments/APKBUILD
index 3d14c75fc2f..a5a2634ce2a 100644
--- a/testing/shipments/APKBUILD
+++ b/testing/shipments/APKBUILD
@@ -25,7 +25,7 @@ options="!check" # There's no testsuite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/slurm/APKBUILD b/testing/slurm/APKBUILD
index 71fd7aebbd7..997602db7f0 100644
--- a/testing/slurm/APKBUILD
+++ b/testing/slurm/APKBUILD
@@ -15,7 +15,7 @@ builddir="$srcdir/$pkgname-upstream-$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/solanum/APKBUILD b/testing/solanum/APKBUILD
index 917cf2efd8f..fd472ba41e2 100644
--- a/testing/solanum/APKBUILD
+++ b/testing/solanum/APKBUILD
@@ -33,7 +33,7 @@ builddir="$srcdir/Solanum-$_gitrev"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/swappy/APKBUILD b/testing/swappy/APKBUILD
index 8f2455062fb..8512e055789 100644
--- a/testing/swappy/APKBUILD
+++ b/testing/swappy/APKBUILD
@@ -15,7 +15,7 @@ source="https://github.com/jtheoof/swappy/archive/v$pkgver/swappy-$pkgver.tar.gz
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/tang/APKBUILD b/testing/tang/APKBUILD
index cb688b19360..c84f562173d 100644
--- a/testing/tang/APKBUILD
+++ b/testing/tang/APKBUILD
@@ -26,7 +26,7 @@ prepare() {
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/tangram/APKBUILD b/testing/tangram/APKBUILD
index fd7c313b62c..24a1963cc73 100644
--- a/testing/tangram/APKBUILD
+++ b/testing/tangram/APKBUILD
@@ -45,7 +45,7 @@ prepare() {
build() {
abuild-meson \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/termbox/APKBUILD b/testing/termbox/APKBUILD
index 5b1924ef393..39d874c66ba 100644
--- a/testing/termbox/APKBUILD
+++ b/testing/termbox/APKBUILD
@@ -23,7 +23,7 @@ build() {
abuild-meson \
--default-library=both \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/thumbdrives/APKBUILD b/testing/thumbdrives/APKBUILD
index d629407ad10..9a368a3edd1 100644
--- a/testing/thumbdrives/APKBUILD
+++ b/testing/thumbdrives/APKBUILD
@@ -13,7 +13,7 @@ options="!check" # There's no testsuite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/uasm/APKBUILD b/testing/uasm/APKBUILD
index 84d3a7a4aaf..3bb3f95f2b5 100644
--- a/testing/uasm/APKBUILD
+++ b/testing/uasm/APKBUILD
@@ -16,7 +16,7 @@ source="
builddir="${srcdir}/UASM-${_commitish}/"
build() {
- make ${JOBS:+-j ${JOBS}} -f "gccLinux64.mak"
+ make -f "gccLinux64.mak"
}
package() {
diff --git a/testing/viewnior/APKBUILD b/testing/viewnior/APKBUILD
index 9b87768735c..b353f9c757c 100644
--- a/testing/viewnior/APKBUILD
+++ b/testing/viewnior/APKBUILD
@@ -15,7 +15,7 @@ builddir="$srcdir"/$_pkgname-$pkgname-$pkgver
build() {
abuild-meson builddir
- meson compile ${JOBS:+-j ${JOBS}} -C builddir
+ meson compile -C builddir
}
package() {
diff --git a/testing/wbg/APKBUILD b/testing/wbg/APKBUILD
index 8c521365ac4..c1a54e6594c 100644
--- a/testing/wbg/APKBUILD
+++ b/testing/wbg/APKBUILD
@@ -22,7 +22,7 @@ builddir="$srcdir/$pkgname"
build() {
abuild-meson \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wcm/APKBUILD b/testing/wcm/APKBUILD
index b85aba1b65c..6c3bb21aef1 100644
--- a/testing/wcm/APKBUILD
+++ b/testing/wcm/APKBUILD
@@ -13,7 +13,7 @@ source="https://github.com/WayfireWM/wcm/releases/download/v$pkgver/wcm-$pkgver.
build() {
abuild-meson build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
diff --git a/testing/wf-config/APKBUILD b/testing/wf-config/APKBUILD
index 12d0a8aaa14..139de503f6a 100644
--- a/testing/wf-config/APKBUILD
+++ b/testing/wf-config/APKBUILD
@@ -20,7 +20,7 @@ source="https://github.com/WayfireWM/wf-config/releases/download/v$pkgver/wf-con
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wf-osk/APKBUILD b/testing/wf-osk/APKBUILD
index a652e72b0a3..eb1843a4b6f 100644
--- a/testing/wf-osk/APKBUILD
+++ b/testing/wf-osk/APKBUILD
@@ -21,7 +21,7 @@ builddir="$srcdir/$pkgname-$_commit"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wiremapper/APKBUILD b/testing/wiremapper/APKBUILD
index d095308ae6a..0c67d691883 100644
--- a/testing/wiremapper/APKBUILD
+++ b/testing/wiremapper/APKBUILD
@@ -14,7 +14,7 @@ options="!check" # There's no testsuite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wlavu/APKBUILD b/testing/wlavu/APKBUILD
index 012a481c438..aa8ecf64f80 100644
--- a/testing/wlavu/APKBUILD
+++ b/testing/wlavu/APKBUILD
@@ -20,7 +20,7 @@ builddir="$srcdir/$pkgname-$_commit"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wlclock/APKBUILD b/testing/wlclock/APKBUILD
index 1e895a2db17..83f308cb656 100644
--- a/testing/wlclock/APKBUILD
+++ b/testing/wlclock/APKBUILD
@@ -21,7 +21,7 @@ options="!check" # no test suite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wlrobs/APKBUILD b/testing/wlrobs/APKBUILD
index fb574c197ac..735ee779644 100644
--- a/testing/wlrobs/APKBUILD
+++ b/testing/wlrobs/APKBUILD
@@ -31,7 +31,7 @@ build() {
abuild-meson \
-Duse_dmabuf=true \
build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
diff --git a/testing/wlroots0.12/APKBUILD b/testing/wlroots0.12/APKBUILD
index 13b6542ea0d..f178ac4f577 100644
--- a/testing/wlroots0.12/APKBUILD
+++ b/testing/wlroots0.12/APKBUILD
@@ -39,7 +39,7 @@ build() {
-Dlogind-provider=elogind \
-Dexamples=false \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
diff --git a/testing/wlroots0.15/APKBUILD b/testing/wlroots0.15/APKBUILD
index 7d66f44ef77..388f9755201 100644
--- a/testing/wlroots0.15/APKBUILD
+++ b/testing/wlroots0.15/APKBUILD
@@ -44,7 +44,7 @@ build() {
-Db_lto=true \
-Dexamples=false \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {
diff --git a/testing/wlvncc/APKBUILD b/testing/wlvncc/APKBUILD
index a21a166a8f5..1d07c11d133 100644
--- a/testing/wlvncc/APKBUILD
+++ b/testing/wlvncc/APKBUILD
@@ -33,7 +33,7 @@ build() {
abuild-meson \
-Db_lto=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
diff --git a/testing/wmenu/APKBUILD b/testing/wmenu/APKBUILD
index 274ba709273..377350f4dd4 100644
--- a/testing/wmenu/APKBUILD
+++ b/testing/wmenu/APKBUILD
@@ -21,7 +21,7 @@ source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~adnano/wmenu/archive/$pkgver
build() {
abuild-meson \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/wshowkeys/APKBUILD b/testing/wshowkeys/APKBUILD
index b9067b6b88f..46308a5ee73 100644
--- a/testing/wshowkeys/APKBUILD
+++ b/testing/wshowkeys/APKBUILD
@@ -24,7 +24,7 @@ options="!check suid" # has no test suite; needs to be setuid to read input even
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
diff --git a/testing/zathura-djvu/APKBUILD b/testing/zathura-djvu/APKBUILD
index c5ed9c01b4d..3332369bae6 100644
--- a/testing/zathura-djvu/APKBUILD
+++ b/testing/zathura-djvu/APKBUILD
@@ -13,7 +13,7 @@ source="https://pwmt.org/projects/zathura-djvu/download/zathura-djvu-$pkgver.tar
build() {
abuild-meson build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
package() {