summaryrefslogtreecommitdiff
path: root/testing/whipper/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/whipper/APKBUILD')
-rw-r--r--testing/whipper/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/testing/whipper/APKBUILD b/testing/whipper/APKBUILD
index a7e474b0113..2cecc0474dd 100644
--- a/testing/whipper/APKBUILD
+++ b/testing/whipper/APKBUILD
@@ -24,18 +24,10 @@ depends="
flac
sox
"
-makedepends="py3-setuptools python3-dev py3-wheel libsndfile-dev"
-checkdepends="py3-setuptools_scm py3-twisted"
+makedepends="py3-setuptools py3-setuptools_scm python3-dev py3-wheel libsndfile-dev"
+checkdepends="py3-twisted"
source="$pkgname-$pkgver.tar.gz::https://github.com/whipper-team/whipper/archive/v$pkgver.tar.gz"
-prepare() {
- default_prepare
-
- sed -e '/setuptools_scm/d' \
- -e "s/use_scm_verion=True/version='$pkgver'/" \
- -i setup.py
-}
-
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver"
@@ -47,8 +39,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 setup.py install --skip-build --root="$pkgdir"
}
+
sha512sums="
728ad98185aa2d29f4fb215a597136691bb2c3590b3cac4f659238f90a3b4328c377fafe830a725b655f050538739f404b3eca853db4c39001d1b9d721dc7fd8 whipper-0.10.0.tar.gz
"