summaryrefslogtreecommitdiff
path: root/testing/up/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/up/APKBUILD')
-rw-r--r--testing/up/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/up/APKBUILD b/testing/up/APKBUILD
index 5254c3b06b1..78ac99f580a 100644
--- a/testing/up/APKBUILD
+++ b/testing/up/APKBUILD
@@ -10,6 +10,10 @@ license="Apache-2.0"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/akavel/up/archive/refs/tags/v$pkgver.tar.gz"
+export GOCACHE="$srcdir/go-cache"
+export GOTMPDIR="$srcdir"
+export GOMODCACHE="$srcdir/go"
+
build() {
go build -v -o bin/$pkgname
}