summaryrefslogtreecommitdiff
path: root/testing/obfs4proxy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/obfs4proxy/APKBUILD')
-rw-r--r--testing/obfs4proxy/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/obfs4proxy/APKBUILD b/testing/obfs4proxy/APKBUILD
index c394b189c4e..a75518ef651 100644
--- a/testing/obfs4proxy/APKBUILD
+++ b/testing/obfs4proxy/APKBUILD
@@ -12,7 +12,9 @@ options="!strip chmod-clean"
source="$pkgname-$pkgver.tar.gz::https://github.com/Yawning/obfs4/archive/obfs4proxy-$pkgver.tar.gz"
builddir="$srcdir"/obfs4-$pkgname-$pkgver
-export GOPATH="$srcdir"
+export GOCACHE="$srcdir/go-cache"
+export GOTMPDIR="$srcdir"
+export GOMODCACHE="$srcdir/go"
build() {
go build -v -o ./$pkgname-executable ./$pkgname