summaryrefslogtreecommitdiff
path: root/testing/kopia/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kopia/APKBUILD')
-rw-r--r--testing/kopia/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/kopia/APKBUILD b/testing/kopia/APKBUILD
index eb367f326dd..68d5a01591e 100644
--- a/testing/kopia/APKBUILD
+++ b/testing/kopia/APKBUILD
@@ -14,12 +14,14 @@ source="https://github.com/kopia/kopia/archive/v$pkgver/kopia-$pkgver.tar.gz
skip-docker-tests.patch
"
+export GOCACHE="$srcdir/go-cache"
+export GOTMPDIR="$srcdir"
+export GOMODCACHE="$srcdir/go"
export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GOPATH="$srcdir"
export CGO_ENABLED=0
build() {
- go build -ldflags "-s -w -X github.com/kopia/kopia/repo.BuildVersion=$pkgver"
+ go build -ldflags "-X github.com/kopia/kopia/repo.BuildVersion=$pkgver"
./kopia --completion-script-bash > $pkgname.bash
./kopia --completion-script-zsh > $pkgname.zsh