summaryrefslogtreecommitdiff
path: root/testing/clash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/clash/APKBUILD')
-rw-r--r--testing/clash/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/clash/APKBUILD b/testing/clash/APKBUILD
index 8e399d6f3d2..e50bde333e9 100644
--- a/testing/clash/APKBUILD
+++ b/testing/clash/APKBUILD
@@ -13,9 +13,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/Dreamacro/clash/archive/refs
clash.initd"
options="!check" # The upstream does not provide a proper way to test the pakcage
-export GOCACHE="$srcdir/go-cache"
-export GOTMPDIR="$srcdir"
-export GOMODCACHE="$srcdir/go"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
export GOFLAGS="$GOFLAGS -modcacherw"
build() {