summaryrefslogtreecommitdiff
path: root/main/dahdi-tools
diff options
context:
space:
mode:
Diffstat (limited to 'main/dahdi-tools')
-rw-r--r--main/dahdi-tools/APKBUILD49
-rw-r--r--main/dahdi-tools/dahdi-tools.initd21
-rw-r--r--main/dahdi-tools/fix-musl.patch36
3 files changed, 0 insertions, 106 deletions
diff --git a/main/dahdi-tools/APKBUILD b/main/dahdi-tools/APKBUILD
deleted file mode 100644
index c6bb6e50937..00000000000
--- a/main/dahdi-tools/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Timo Teras <timo.teras@iki.fi>
-# Maintainer: Timo Teras <timo.teras@iki.fi>
-pkgname=dahdi-tools
-pkgver=3.2.0
-pkgrel=0
-pkgdesc="Digium Asterisk Hardware Device Interface management utilities"
-url="https://www.asterisk.org"
-arch="all"
-license="GPL-2.0-or-later"
-depends_dev="bsd-compat-headers linux-headers dahdi-linux-dev newt-dev"
-makedepends="perl file autoconf automake libtool $depends_dev"
-subpackages="$pkgname-doc $pkgname-dev"
-source="https://downloads.digium.com/pub/telephony/dahdi-tools/releases/dahdi-tools-$pkgver.tar.gz
- fix-musl.patch
- $pkgname.initd
- "
-
-prepare() {
- default_prepare
- autoreconf -fi
-}
-
-
-build() {
- eval local $(perl -V:vendorlib)
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/infoa \
- --with-perllib="$vendorlib"
- sed -i -e 's/$(CC) $(LDFLAGS) -o $@ $^/$(CC) $^ $(LDFLAGS) -o $@/' \
- Makefile
- make
-}
-
-package() {
- make -j1 DESTDIR="$pkgdir" install
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/dahdi
- rm -rf "$pkgdir"/usr/lib/dracut # We use mkinitfs, not dracut
-}
-
-sha512sums="
-29df9a768c6db872bd51926dac11178400a03e2e1d0771ae163433ce300af71691f5c7a60f8756c0e6cef8a43f1331944cb4e44393f04a0ff8dee19bc9e7cf16 dahdi-tools-3.2.0.tar.gz
-45955caf04368ff30d60db0b3e892d940c9ac0422b337186ed251108ce25ab305d4590efff452f53f160a53fcd26a273f21d6d093307b426a3a2a6df53584daa fix-musl.patch
-3850ab9e323ec31d676d311c97d0cde70b809379b6c01c8ff6d5a01a860eb43bf3f18f2de53e952365d17f40638c7cb0481682d96cea5b7fdb1423d3e762e2f3 dahdi-tools.initd
-"
diff --git a/main/dahdi-tools/dahdi-tools.initd b/main/dahdi-tools/dahdi-tools.initd
deleted file mode 100644
index 42092c7375b..00000000000
--- a/main/dahdi-tools/dahdi-tools.initd
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/sbin/openrc-run
-
-conf=/etc/dahdi/system.conf
-
-depend() {
- before asterisk
- after hwdrivers modules
- keyword novserver
-}
-
-start() {
- ebegin "Starting dahdi"
- /usr/sbin/dahdi_cfg
- eend $?
-}
-
-stop() {
- ebegin "Stopping dahdi"
- /usr/sbin/dahdi_cfg -s
- eend $?
-}
diff --git a/main/dahdi-tools/fix-musl.patch b/main/dahdi-tools/fix-musl.patch
deleted file mode 100644
index 01a0a302bf1..00000000000
--- a/main/dahdi-tools/fix-musl.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ru dahdi-tools-2.11.1.orig/xpp/hexfile.h dahdi-tools-2.11.1/xpp/hexfile.h
---- dahdi-tools-2.11.1.orig/xpp/hexfile.h 2016-03-02 00:04:19.000000000 +0200
-+++ dahdi-tools-2.11.1/xpp/hexfile.h 2017-05-29 09:30:50.034438806 +0300
-@@ -26,6 +26,7 @@
- #include <stdarg.h>
- #include <stdio.h>
- #include <stdint.h>
-+#include <sys/cdefs.h>
- #include <sys/param.h>
- #include <syslog.h>
- #define PACKED __attribute__((packed))
-diff -ru dahdi-tools-2.11.1.orig/xpp/xtalk/debug.c dahdi-tools-2.11.1/xpp/xtalk/debug.c
---- dahdi-tools-2.11.1.orig/xpp/xtalk/debug.c 2016-03-02 00:04:19.000000000 +0200
-+++ dahdi-tools-2.11.1/xpp/xtalk/debug.c 2017-05-29 09:30:02.193881232 +0300
-@@ -26,7 +26,6 @@
- #include <stdlib.h>
- #include <stdarg.h>
- #include <syslog.h>
--#include <execinfo.h>
- #include <xtalk/debug.h>
- #include <autoconfig.h>
-
-@@ -61,6 +60,7 @@
- /* from glibc info(1) */
- void print_backtrace(FILE *fp)
- {
-+#if 0
- void *array[10];
- size_t size;
- char **strings;
-@@ -71,4 +71,5 @@
- for (i = 0; i < size; i++)
- fprintf(fp, "%s\n", strings[i]);
- free(strings);
-+#endif
- }