summaryrefslogtreecommitdiff
path: root/community/libretro-craft/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libretro-craft/APKBUILD')
-rw-r--r--community/libretro-craft/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/libretro-craft/APKBUILD b/community/libretro-craft/APKBUILD
index de11063d9b9..3f39256517d 100644
--- a/community/libretro-craft/APKBUILD
+++ b/community/libretro-craft/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: David Demelier <markand@malikania.fr>
pkgname=libretro-craft
pkgver=0_git20230109
-pkgrel=0
+pkgrel=1
_commit="fce88570e83003b24cce34085928c890adae141d"
pkgdesc="a simple Minecraft clone written in C using modern OpenGL"
url="https://github.com/libretro/Craft"
@@ -14,6 +14,8 @@ builddir="$srcdir/Craft-$_commit"
options="!check" # No tests
build() {
+ # Enable POSIX features with -D_DEFAULT_SOURCE
+ export CFLAGS="$CFLAGS -D_DEFAULT_SOURCE"
make -f Makefile.libretro
}