summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/weston/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/weston/APKBUILD b/community/weston/APKBUILD
index 26e45de06a7..8aa81461298 100644
--- a/community/weston/APKBUILD
+++ b/community/weston/APKBUILD
@@ -124,13 +124,13 @@ _sub() {
local name path
case $subpkgname in
*-shell-*)
- name=${subpkgname#$pkgname-shell-}
+ name=${subpkgname#"$pkgname"-shell-}
path=/usr/lib/$pkgname
pkgdesc="Weston shell: $name"
- name=*$name-shell*
+ name="*$name-shell*"
;;
*-backend-*)
- name=${subpkgname#$pkgname-backend-}
+ name=${subpkgname#"$pkgname"-backend-}
path=/usr/lib/$_libdir
pkgdesc="Weston backend: $name"
name=$name-backend.so
@@ -139,7 +139,7 @@ _sub() {
*)
name=$subpkgname
path=/usr/bin
- [ -x "$pkgdir"/$path/$name ] || name=${subpkgname#$pkgname-}
+ [ -x "$pkgdir"/$path/$name ] || name=${subpkgname#"$pkgname"-}
pkgdesc="Weston client: $name"
;;
esac