summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/bandwhich/APKBUILD11
-rw-r--r--community/bandwhich/update-rust-libc.patch16
2 files changed, 4 insertions, 23 deletions
diff --git a/community/bandwhich/APKBUILD b/community/bandwhich/APKBUILD
index a4d2316d45c..35ae6d1b25a 100644
--- a/community/bandwhich/APKBUILD
+++ b/community/bandwhich/APKBUILD
@@ -1,16 +1,14 @@
# Contributor: Anjandev Momi <anjan@momi.ca>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=bandwhich
-pkgver=0.22.2
-pkgrel=1
+pkgver=0.23.0
+pkgrel=0
pkgdesc="Terminal bandwidth utilization tool"
url="https://github.com/imsnif/bandwhich"
arch="all"
license="MIT"
makedepends="cargo cargo-auditable"
-source="https://github.com/imsnif/bandwhich/archive/v$pkgver/bandwhich-$pkgver.tar.gz
- update-rust-libc.patch
- "
+source="https://github.com/imsnif/bandwhich/archive/v$pkgver/bandwhich-$pkgver.tar.gz"
prepare() {
default_prepare
@@ -31,6 +29,5 @@ package() {
}
sha512sums="
-0709b7eb4d3656e8a547d4caf90b285b22c366cbf3fd03c1b1db06add502cfe39336c07f4cb2a962ae4ff6383b9a1e5b75cad4e74a9057a864fbfcdb9fbd530b bandwhich-0.22.2.tar.gz
-c7bbf2f7ef0a24fc0a74ad02797b5c23a4767a59519d49801058a39c7d4c258ffe5db8633b49453b852409111e00332bc466be039c1882dda30b0bfd7fa3fe27 update-rust-libc.patch
+888c5fa568b944c28ae6903a8cdf6e4faf3a82b3484d579766dddfe048d1f1680951e0a136947287ef1ba47369a44a5306fbac9bfe7d5c6066b0ebb7126afb28 bandwhich-0.23.0.tar.gz
"
diff --git a/community/bandwhich/update-rust-libc.patch b/community/bandwhich/update-rust-libc.patch
deleted file mode 100644
index 740a7cc1734..00000000000
--- a/community/bandwhich/update-rust-libc.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/Cargo.lock b/Cargo.lock
-index 2742af2..e376311 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -944,9 +944,9 @@ checksum = "e2abad23fbc42b3700f2f279844dc832adb2b2eb069b2df918f455c4e18cc646"
-
- [[package]]
- name = "libc"
--version = "0.2.152"
-+version = "0.2.155"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "13e3bf6590cbc649f4d1a3eefc9d5d6eb746f5200ffb04e5e142700b8faa56e7"
-+checksum = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
-
- [[package]]
- name = "linked-hash-map"