summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--testing/py3-gitpython/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-gitpython/APKBUILD b/testing/py3-gitpython/APKBUILD
new file mode 100644
index 00000000000..9bbf40d58c0
--- /dev/null
+++ b/testing/py3-gitpython/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-gitpython
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="Python3 Git Library"
+options="!check" # Requires unpackaged 'ddt'
+url="https://github.com/gitpython-developers/GitPython"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-gitdb2"
+makedepends="python3-dev py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/GitPython/archive/$pkgver.tar.gz"
+builddir="$srcdir/GitPython-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="242999137a72104b56536d1fa5541b005f9e545399de467d82e6db696b75838320140437df230672fca8683321a23b0bae6e30ac2c3c1808792b8e7bd1c9da55 py3-gitpython-3.0.2.tar.gz"