summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--main/lxc/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 378798961aa..51ed3d44399 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -4,7 +4,7 @@
pkgname=lxc
pkgver=6.0.0
_pkgver=${pkgver/_rc/.rc}
-pkgrel=1
+pkgrel=2
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
@@ -34,6 +34,7 @@ subpackages="
$pkgname-download:_download:noarch
$pkgname-templates-oci:templates_oci:noarch
$pkgname-templates::noarch
+ $pkgname-user-nic:_user_nic
"
source="https://linuxcontainers.org/downloads/lxc/lxc-$_pkgver.tar.gz
lxc.initd
@@ -166,6 +167,12 @@ bridge() {
EOF
}
+_user_nic() {
+ pkgdesc="suid helper to manage LXC network interfaces as unprivileged user"
+
+ amove usr/libexec/lxc/lxc-user-nic
+}
+
sha512sums="
acff2fc70cf2c65af37b70a21239482c3d845c408f7132558b54980e4400c23670c63178a3a3dfb239f047f529004df93cd829d728852a8c8647ce6babf7857f lxc-6.0.0.tar.gz
db71783366277a68a5c8116604cf845da4780fe4aebdb5820ae2c4fe028cfe52a9c94246db362476f2f195be6a9c2b835edbe521423f116fc66eb50023d6daab lxc.initd