summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--testing/kgx/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/kgx/APKBUILD b/testing/kgx/APKBUILD
new file mode 100644
index 00000000000..f3b49a10c7a
--- /dev/null
+++ b/testing/kgx/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: David Heidelberg <david@ixit.cz>
+# Contributor: David Heidelberg <david@ixit.cz>
+pkgname=kgx
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="A minimal terminal for GNOME"
+url="https://gitlab.gnome.org/ZanderBrown/kgx"
+arch="all !s390x !ppc64le" # !s390x !ppc64le due gnome-shell
+license="GPL-3.0-only"
+options="!check" # Tests require GIR
+depends="dbus desktop-file-utils gsettings-desktop-schemas"
+makedepends="dconf-dev gnome-shell gsettings-desktop-schemas-dev nautilus-dev vte3-dev
+ glib-dev intltool itstool libhandy-dev libgtop-dev pcre2-dev meson vala"
+subpackages="$pkgname-lang"
+source="https://gitlab.gnome.org/ZanderBrown/kgx/-/archive/$pkgver/kgx-$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ -Dgtop=true \
+ -Dgtk_doc=false \
+ -Dgir=false \
+ -Dgeneric=true \
+ -Dtests=false \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="f1d19661472cec0f8cab30ba38608d5d7029f56d85bd99b315c841ae859059ef8ab90add0c530dcc3d95ba00e67bbb9127e537ceea5165c5e47c382a15445502 kgx-0.2.1.tar.gz"