summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--main/iptables/APKBUILD3
-rw-r--r--main/iptables/iptables.post-upgrade14
2 files changed, 16 insertions, 1 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 0fb2a11720d..f33cb883506 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iptables
pkgver=1.8.9
-pkgrel=3
+pkgrel=4
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="https://www.netfilter.org/projects/iptables/index.html"
arch="all"
license="GPL-2.0-or-later"
depends_dev="linux-headers"
+install="$pkgname.post-upgrade"
makedepends="$depends_dev libnftnl-dev bison flex autoconf automake"
subpackages="
iptables-legacy
diff --git a/main/iptables/iptables.post-upgrade b/main/iptables/iptables.post-upgrade
new file mode 100644
index 00000000000..8b1065dc5a0
--- /dev/null
+++ b/main/iptables/iptables.post-upgrade
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+ver_old=$2
+
+if [ "$(apk version -t "$ver_old" '1.8.9-r4')" = '<' ]; then
+ cat >&2 <<-EOF
+ *
+ * the "iptables" commands now point to xtables-nft-multi
+ * instead of xtables-legacy-multi. this means that by default,
+ * the kernel nftables backend is used instead of the iptables one.
+ * because mixing backends is not supported, you should reboot your system.
+ *
+ EOF
+fi