summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/aws-cli/APKBUILD10
-rw-r--r--community/aws-cli/aws-cli-v2-8838.patch23
-rw-r--r--community/aws-cli/aws-cli-v2-ruamel-yaml-v4.patch7
3 files changed, 29 insertions, 11 deletions
diff --git a/community/aws-cli/APKBUILD b/community/aws-cli/APKBUILD
index 620a6377f8e..f6f951b47a7 100644
--- a/community/aws-cli/APKBUILD
+++ b/community/aws-cli/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: fossdd <fossdd@pwned.life>
pkgname=aws-cli
-pkgver=2.17.13
+pkgver=2.17.27
pkgrel=0
pkgdesc="Universal Command Line Interface for Amazon Web Services (v2)"
url="https://github.com/aws/aws-cli"
@@ -21,7 +21,7 @@ depends="
py3-jmespath
py3-urllib3
py3-prompt_toolkit
- py3-ruamel.yaml<0.17.29
+ py3-ruamel.yaml
python3
"
makedepends="
@@ -45,6 +45,7 @@ subpackages="
"
source="$pkgname-$pkgver.tar.gz::https://github.com/aws/aws-cli/archive/$pkgver.tar.gz
allow-egg-info.patch
+ aws-cli-v2-8838.patch
aws-cli-v2-ruamel-yaml-v4.patch
aws-cli-v2-tz-fix.patch
botocore-2551.patch
@@ -137,9 +138,10 @@ doc() {
}
sha512sums="
-a2928d908808c3c983f32d5f5d9230465dd68e0a4def3b0f5fa30eca3f36e8172460ad130b6af5b35700ebfc45a68addc9aea14565613bb0ed955f52a556e816 aws-cli-2.17.13.tar.gz
+20c7677f074c4faaabc178229b9c38e65b4a11c1d30c58caedbe96736285af74c89351727bfbdb206b21821d3aa37be229f182ebabce9cb5c0ee102d13d72386 aws-cli-2.17.27.tar.gz
3780a1b8af4d0098315beacd9a6a7cb4ebac08d4c1194dc55b5db6f0a28c46e45da85f0b94da2e005c5327686f8c4a2b99ee45b3cf847b3bbf5d82c80b433f50 allow-egg-info.patch
-ed05961344a0acb8c7b8aaf913f8e782c90ece23aa89006112e9b1c2ea6d0cfa21efc6b38ac1f6b604182b09824675fe6ef68f6394c3b10dfa9e75f82c7cd387 aws-cli-v2-ruamel-yaml-v4.patch
+74651082bfd8407bfe2d8febfb90fe036f35b54066a3b6eeb4d8079acb2ed19e96476dae83c9e33f0ed747e2c9875023f457ecd8ac20d36a54fb4e5b7acf8724 aws-cli-v2-8838.patch
+b302264d7f28e69701b46fdcd38e2104e5f4ebb064605211c1d92983d0f6732626b4e80bff026547b2216ea69a05010f07ec3f14377539f40cfd889e6044bd94 aws-cli-v2-ruamel-yaml-v4.patch
66c813b52d1fa402d89cd4381237175b3c8f52546e60f4a9703c27281f4a27d579751b90468a84208f94743b3c58e041cf9e9c9f28387ea06897575db8e46946 aws-cli-v2-tz-fix.patch
e0647b8690c139617da696318124b74a19b938c56d836f6531a86e031ec9fd9e43798807a3519d78c9abba59aa8b6679623dc75b579ce57ebb4dff55569fa18d botocore-2551.patch
0b47b8329863dd71e4aeac18eb1175b47a68e45df0becae738ec3bf72f908cf96f99dffd7714c3835e014b1c100701a6652e1db3d2e415162fcc9c8a098cf201 botocore-2922.patch
diff --git a/community/aws-cli/aws-cli-v2-8838.patch b/community/aws-cli/aws-cli-v2-8838.patch
new file mode 100644
index 00000000000..5dfbcf7cfec
--- /dev/null
+++ b/community/aws-cli/aws-cli-v2-8838.patch
@@ -0,0 +1,23 @@
+From b5f19fe136ab0752cd5fcab21ff0ab59bddbea99 Mon Sep 17 00:00:00 2001
+From: fossdd <fossdd@pwned.life>
+Date: Fri, 2 Aug 2024 08:25:09 +0000
+Subject: [PATCH] Use higher key size for TestSha256RSADigestValidator
+
+cryptography 43.0.0 requires bumped the minimum key size to 1024
+---
+ tests/unit/customizations/cloudtrail/test_validation.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/unit/customizations/cloudtrail/test_validation.py b/tests/unit/customizations/cloudtrail/test_validation.py
+index c520ab57e940..96bee0ff7d5a 100644
+--- a/tests/unit/customizations/cloudtrail/test_validation.py
++++ b/tests/unit/customizations/cloudtrail/test_validation.py
+@@ -362,7 +362,7 @@ def setUp(self):
+ self._digest_data['_signature'] = 'aeff'
+
+ def test_validates_digests(self):
+- private_key = rsa.generate_private_key(65537, 512, default_backend())
++ private_key = rsa.generate_private_key(65537, 1024, default_backend())
+ sha256_hash = hashlib.sha256(self._inflated_digest)
+ string_to_sign = "%s\n%s/%s\n%s\n%s" % (
+ self._digest_data['digestEndTime'],
diff --git a/community/aws-cli/aws-cli-v2-ruamel-yaml-v4.patch b/community/aws-cli/aws-cli-v2-ruamel-yaml-v4.patch
index 0972e8d3707..efba03d70c5 100644
--- a/community/aws-cli/aws-cli-v2-ruamel-yaml-v4.patch
+++ b/community/aws-cli/aws-cli-v2-ruamel-yaml-v4.patch
@@ -34,13 +34,6 @@ index fef9a3068d5..1e436a88149 100644
# ruamel.yaml only requires ruamel.yaml.clib for Python versions
# less than or equal to Python 3.10. In order to ensure we have
# a consistent dependency closure across all Python versions,
-@@ -98,4 +98,4 @@ filterwarnings = [
- ]
-
- [tool.black]
--line-length = 80
-\ No newline at end of file
-+line-length = 80
diff --git a/tests/functional/eks/testdata/output_combined b/tests/functional/eks/testdata/output_combined
index 8e9ce098f72..8e30727da6e 100644
--- a/tests/functional/eks/testdata/output_combined