summaryrefslogtreecommitdiff
path: root/unmaintained/py3-aiohttp-cors-gns3
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-03-17 10:59:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-04-05 18:18:26 +0000
commitb45777e14fcfefc047b4a46d2489fc575583fe68 (patch)
tree67577ecb1fef4024ca1db857fd9de49b0361ece0 /unmaintained/py3-aiohttp-cors-gns3
parent49142690f33503d2f1fe07fe3d3ca3de6365ad7e (diff)
downloadaports-b45777e14fcfefc047b4a46d2489fc575583fe68.zip
move *gns3* to unmantained so we can upgrade to python 3.9
The pinned versions does not work with python 3.9. Specifically py3-yarl-gns3 test suite fails with the py3-multidict-gns3 while py3-yarl works with the py3-multidict. We should either relax the dependencies or let end users install it with pip.
Diffstat (limited to 'unmaintained/py3-aiohttp-cors-gns3')
-rw-r--r--unmaintained/py3-aiohttp-cors-gns3/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/unmaintained/py3-aiohttp-cors-gns3/APKBUILD b/unmaintained/py3-aiohttp-cors-gns3/APKBUILD
new file mode 100644
index 00000000000..0844144a05b
--- /dev/null
+++ b/unmaintained/py3-aiohttp-cors-gns3/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-aiohttp-cors-gns3
+_pkgname=aiohttp_cors
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="CORS support for aiohttp - GNS3 compatible version"
+url="https://github.com/aio-libs/aiohttp-cors"
+arch="noarch"
+license="Apache-2.0"
+depends="py3-aiohttp-gns3 !py3-aiohttp-cors"
+makedepends="python3-dev py3-setuptools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp-cors/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/aiohttp-cors-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="72e0b365b952c08a02c1123d7672cfea01063e2ff01743a71e10f804d22178edc0f1c6b7f87b7ed484ca7c24e89a32de90d0d279f2f5c060427319182f9bdd3b aiohttp_cors-0.7.0.tar.gz"