summaryrefslogtreecommitdiff
path: root/unmaintained/profanity
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/profanity
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.zip
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/profanity')
-rw-r--r--unmaintained/profanity/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/unmaintained/profanity/APKBUILD b/unmaintained/profanity/APKBUILD
new file mode 100644
index 00000000000..470e2c9ff93
--- /dev/null
+++ b/unmaintained/profanity/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+# Maintainer:
+pkgname=profanity
+pkgver=0.4.7
+pkgrel=0
+pkgdesc="Console based XMPP client"
+url="http://www.profanity.im"
+arch=all
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="curl-dev expat-dev glib-dev libotr-dev
+ libstrophe-dev readline-dev util-linux-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-themes"
+source="http://www.profanity.im/profanity-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples
+ install -m644 profrc.example \
+ "$pkgdir"/usr/share/doc/$pkgname/examples || return 1
+}
+
+themes() {
+ pkgdesc="UI themes for $pkgname"
+ arch="noarch"
+
+ mkdir -p "$subpkgdir"/usr/share/$pkgname
+ mv "$pkgdir"/usr/share/$pkgname/themes \
+ "$subpkgdir"/usr/share/$pkgname || return 1
+}
+
+md5sums="f044c54c7fee23ab8c4be7228a6bea9b profanity-0.4.7.tar.gz"
+sha256sums="b02c4e029fe84941050ccab6c8cdf5f15df23de5d1384b4d1ec66da6faee11dd profanity-0.4.7.tar.gz"
+sha512sums="805adddbdf41334a2903707ce871f39c36c70639dc4c872cfd36769af36aa3597b05aa9ba719452bcbe8011cc73ac717cee7016c928083cd46c922732ca10568 profanity-0.4.7.tar.gz"