summaryrefslogtreecommitdiff
path: root/unmaintained/kubergrunt
diff options
context:
space:
mode:
authorHoang Nguyen <folliekazetani@protonmail.com>2022-12-18 11:00:00 +0700
committeralice <alice@ayaya.dev>2022-12-17 19:47:45 +0000
commite2f71c0263b61aa1d35b1551ef1d704fec7e4453 (patch)
tree8623b8898b698533ca490430c0895b334fb7a126 /unmaintained/kubergrunt
parent20793dbc9b7504f5f2b45ecd5b5df7e7a03b7dac (diff)
downloadaports-e2f71c0263b61aa1d35b1551ef1d704fec7e4453.zip
unmaintained/kubergrunt: move from testing
I don't actively use AWS or EKS anymore, so this package should be orphaned.
Diffstat (limited to 'unmaintained/kubergrunt')
-rw-r--r--unmaintained/kubergrunt/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/unmaintained/kubergrunt/APKBUILD b/unmaintained/kubergrunt/APKBUILD
new file mode 100644
index 00000000000..9faf296a973
--- /dev/null
+++ b/unmaintained/kubergrunt/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer:
+pkgname=kubergrunt
+pkgver=0.9.3
+pkgrel=3
+pkgdesc="Binary with a collection of commands to fill the gaps between Terraform, Helm and Kubectl"
+url="https://www.gruntwork.io/"
+arch="all"
+license="Apache-2.0"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gruntwork-io/kubergrunt/archive/refs/tags/v$pkgver.tar.gz"
+options="!check" # Tests require a running Kubernetes cluster
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ go build -v -o bin/$pkgname -ldflags "-X main.VERSION=v$pkgver" ./cmd
+}
+
+package() {
+ install -Dm755 bin/$pkgname -t "$pkgdir"/usr/bin/
+}
+
+sha512sums="
+749dc349199a2270f3217423dda2b04bfbfa5fbcb6d022a1e17108c5ed6f648483ff3ef8e2d03355ce6d24cc8b561f27f6cac23b148f44bc78b2ad77c20ea5c6 kubergrunt-0.9.3.tar.gz
+"