summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorNoel Kuntze <noel.kuntze@thermi.consulting>2021-08-07 00:30:35 +0200
committerAriadne Conill <ariadne@dereferenced.org>2021-08-07 01:18:35 +0000
commitc65f254caa7f5eb1ce33f13cf2a2b51f1efe77a7 (patch)
tree4b5b0db06d5f76cbe7966e56eebc4f10bfd1bcc2 /testing
parent8940bc16b53e682c082f600bcf5f14043ce46078 (diff)
downloadaports-c65f254caa7f5eb1ce33f13cf2a2b51f1efe77a7.zip
testing/kopano-webapp-spellchecker-languagepack-de-de: fix the ...
custom unpack code to also extract into a new directory for other archive types other than tar.gz And also fix the source URL.
Diffstat (limited to 'testing')
-rw-r--r--testing/kopano-webapp-spellchecker-languagepack-de-de/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/testing/kopano-webapp-spellchecker-languagepack-de-de/APKBUILD b/testing/kopano-webapp-spellchecker-languagepack-de-de/APKBUILD
index 59680216ef9..cf7a1945e54 100644
--- a/testing/kopano-webapp-spellchecker-languagepack-de-de/APKBUILD
+++ b/testing/kopano-webapp-spellchecker-languagepack-de-de/APKBUILD
@@ -2,7 +2,7 @@
pkgname=kopano-webapp-spellchecker-languagepack-de-de
pkgdesc="German (Germany) languagepack for kopano-webapp's spellchecker plugin"
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
# ppc64le, mips64 and riscv64 blocked by libmdbx -> kopano-core -> kopano-webapp
arch="noarch !ppc64le !mips64 !riscv64"
url="https://stash.kopano.io/projects/KWA/repos/spellchecker-languagepack-de-de/browse"
@@ -12,7 +12,7 @@ depends="kopano-webapp-spellchecker"
# kopano-core necessary for mapi php module
makedepends="apache-ant openjdk8 kopano-webapp-src"
source="
- kopano-webapp-spellchecker-languagepack-de-de-$pkgver.zip::https://stash.kopano.io/rest/api/latest/projects/KWA/repos/spellchecker-languagepack-de-de/archive?at=refs%2Ftags%2Fv$pkgver&format=tar.gz
+ kopano-webapp-spellchecker-languagepack-de-de-$pkgver.zip::https://stash.kopano.io/rest/api/latest/projects/KWA/repos/spellchecker-languagepack-de-de/archive?at=refs%2Ftags%2Fv$pkgver&format=zip
"
_pluginname="${pkgname//kopano-webapp-/}"
@@ -47,23 +47,23 @@ unpack() {
$gunzip -c "$s" | tar -C "$new_root_dir" -x ;;
*.tar.bz2)
msg "Unpacking $s..."
- tar -C "$srcdir" -jxf "$s" ;;
+ tar -C "$new_root_dir" -jxf "$s" ;;
*.tar.lz)
msg "Unpacking $s..."
- tar -C "$srcdir" --lzip -xf "$s" ;;
+ tar -C "$new_root_dir" --lzip -xf "$s" ;;
*.tar.lzma)
msg "Unpacking $s..."
- unlzma -T 0 -c "$s" | tar -C "$srcdir" -x ;;
+ unlzma -T 0 -c "$s" | tar -C "$new_root_dir" -x ;;
*.tar.xz)
msg "Unpacking $s..."
local threads_opt
if [ "$(readlink -f "$(command -v unxz)")" != "/bin/busybox" ]; then
threads_opt="--threads=0"
fi
- unxz $threads_opt -c "$s" | tar -C "$srcdir" -x ;;
+ unxz $threads_opt -c "$s" | tar -C "$new_root_dir" -x ;;
*.zip)
msg "Unpacking $s..."
- unzip -n -q "$s" -d "$srcdir" ;;
+ unzip -n -q "$s" -d "$new_root_dir" ;;
esac
done
}
@@ -109,5 +109,5 @@ package() {
fi
}
sha512sums="
-050c8dbd0b17323ae3b84ef5502ef6ff862e9835eba6ba4f9eb92bf8fe94a5e397ef308d4f090e1fa7555897741126234d882737398c4d2d65020af6486d0afe kopano-webapp-spellchecker-languagepack-de-de-2.0.1.zip
+a40092d3a2f835d3c014734addebec9ec8e9dbba2a144d442c61f88e8d46b5cf9c29069feaeaff961813215ce800ec69567fdf9918fed9cdec57b25dd9a80465 kopano-webapp-spellchecker-languagepack-de-de-2.0.1.zip
"