summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-01-19 21:57:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-19 23:49:46 +0100
commitba2ae2f48b61628c04e4976df7522cdf7b8b3620 (patch)
treee3039eeaddf5f87bc4f9890b9f4d52ba4e454621 /testing
parent05c5c08f4907f4ff30734eef4141a9daeb675205 (diff)
downloadaports-ba2ae2f48b61628c04e4976df7522cdf7b8b3620.zip
testing/podman: install configuration files
- add conmon and cni-plugins to dependencies - install default CNI network - patch libpod.conf
Diffstat (limited to 'testing')
-rw-r--r--testing/podman/APKBUILD12
-rw-r--r--testing/podman/libpod-config.patch26
2 files changed, 34 insertions, 4 deletions
diff --git a/testing/podman/APKBUILD b/testing/podman/APKBUILD
index e9e061dd315..d63201dd400 100644
--- a/testing/podman/APKBUILD
+++ b/testing/podman/APKBUILD
@@ -2,15 +2,17 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=podman
pkgver=1.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Simple management tool for pods, containers, and images"
url="https://podman.io/"
options="!check" # TODO: enable tests
arch="all"
license="Apache-2.0"
+depends="conmon cni-plugins"
makedepends="go gpgme-dev libseccomp-dev libassuan-dev go-md2man btrfs-progs-dev bash"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/containers/libpod/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/containers/libpod/archive/v$pkgver.tar.gz
+ libpod-config.patch"
builddir="$srcdir/libpod-$pkgver"
build() {
@@ -20,7 +22,9 @@ build() {
package() {
unset LDFLAGS
- make install.bin install.man PREFIX=/usr DESTDIR="$pkgdir"
+ make install.bin install.man install.cni install.config \
+ PREFIX=/usr DESTDIR="$pkgdir"
}
-sha512sums="986ec7123127d3ffb26cecc39a2ae3d8a6dd3d147327449fc4e9d17f6e6606bde278f13920d0aef59410262801251e7b4cfe099cb5caafe9773533e8476848fe podman-1.7.0.tar.gz"
+sha512sums="986ec7123127d3ffb26cecc39a2ae3d8a6dd3d147327449fc4e9d17f6e6606bde278f13920d0aef59410262801251e7b4cfe099cb5caafe9773533e8476848fe podman-1.7.0.tar.gz
+fb0997502e996ed0b1e99b11970380d4e7a61ab1aa0bf54ec925edd7defbbe2fec67f4cb28ab4a6f0de4ba770ca11c952893a35a0c71f10bd2c3d19f3c836803 libpod-config.patch"
diff --git a/testing/podman/libpod-config.patch b/testing/podman/libpod-config.patch
new file mode 100644
index 00000000000..5d41a731288
--- /dev/null
+++ b/testing/podman/libpod-config.patch
@@ -0,0 +1,26 @@
+diff --git a/libpod.conf b/libpod.conf
+index 7e0228c1..c767b80d 100644
+--- a/libpod.conf
++++ b/libpod.conf
+@@ -24,10 +24,10 @@ conmon_env_vars = [
+ ]
+
+ # CGroup Manager - valid values are "systemd" and "cgroupfs"
+-cgroup_manager = "systemd"
++cgroup_manager = "cgroupfs"
+
+ # Container init binary
+-#init_path = "/usr/libexec/podman/catatonit"
++#init_path = "/usr/bin/catatonit"
+
+ # Directory for persistent libpod files (database, etc)
+ # By default, this will be configured relative to where containers/storage
+@@ -50,6 +50,7 @@ cni_config_dir = "/etc/cni/net.d/"
+
+ # Directories where the CNI plugin binaries may be located
+ cni_plugin_dir = [
++ "/usr/share/cni-plugins/bin",
+ "/usr/libexec/cni",
+ "/usr/lib/cni",
+ "/usr/local/lib/cni",
+