summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-27 15:38:24 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-28 18:04:40 +0100
commitafc14068af713aaebed6f934d6eca6af0dbc99df (patch)
tree22caa508ff06dea8765e658d1073242da280d0b1 /testing
parent3a1f49858957fa725e9e3f18083987980e64c1c0 (diff)
downloadaports-afc14068af713aaebed6f934d6eca6af0dbc99df.zip
testing/telepathy-qt: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/telepathy-qt/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/telepathy-qt/APKBUILD b/testing/telepathy-qt/APKBUILD
new file mode 100644
index 00000000000..e88de3509c3
--- /dev/null
+++ b/testing/telepathy-qt/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=telepathy-qt
+pkgver=0.9.8
+pkgrel=0
+arch="all"
+url="http://telepathy.freedesktop.org/wiki/"
+license="LGPL-2.1-or-later"
+pkgdesc="A library for Qt-based Telepathy clients"
+depends_dev="telepathy-farstream-dev telepathy-glib-dev gstreamer-dev"
+makedepends="$depends_dev cmake python3 qt5-qttools-dev doxygen"
+source="https://telepathy.freedesktop.org/releases/telepathy-qt/telepathy-qt-$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DDESIRED_QT_VERSION=5 \
+ -DENABLE_EXAMPLES=OFF \
+ -DENABLE_TESTS=TRUE
+ make
+
+ doxygen doxygen.cfg
+}
+
+check() {
+ # BaseConnectionManager requires jabber support
+ # BaseProtocol is broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "Base(ConnectionManager|Protocol)"
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ cp -r doc/html "$pkgdir"/usr/share/doc/$pkgname/
+}
+sha512sums="fad662c02417c8e4e239d438ea3549226e589442aea8418c8922a6b78ff88422a36c1cc0d2e3591240fac115390a7fbdb1b4deea98187051cc811175b60b9e8b telepathy-qt-0.9.8.tar.gz"