summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-01-19 21:10:30 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-19 23:50:17 +0100
commita59870fcd31d688e9b6686d5c9741dad16859811 (patch)
treede1fde36f443057d7b6487c012f0dc0e3ce4b1ed /testing
parentba2ae2f48b61628c04e4976df7522cdf7b8b3620 (diff)
downloadaports-a59870fcd31d688e9b6686d5c9741dad16859811.zip
testing/catatonit: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/catatonit/APKBUILD30
-rw-r--r--testing/catatonit/fix-undeclared-identifier.patch13
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/catatonit/APKBUILD b/testing/catatonit/APKBUILD
new file mode 100644
index 00000000000..cdf24ce7893
--- /dev/null
+++ b/testing/catatonit/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=catatonit
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="A container init that is so simple it's effectively brain-dead"
+url="https://github.com/openSUSE/catatonit"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="autoconf automake libtool"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.xz::https://github.com/openSUSE/catatonit/releases/download/v$pkgver/catatonit.tar.xz
+ fix-undeclared-identifier.patch"
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
+
+build() {
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="6f68d0743ccdb59597354d1dbabb85dd07f9432aa59e56982ccae1fd3d160630af14f58ba44c85c57b6f2f4324242105306382d4ba84d38a6621234c82951ac0 catatonit-0.1.4.tar.xz
+e1b77829cf76b49904ec51799b2b95ba94d482bc8038714c1363655e2e22dd1467cb906423873facf270ea6f64df0956a8e0ebad8a2892bebeacecdce9115fcf fix-undeclared-identifier.patch"
diff --git a/testing/catatonit/fix-undeclared-identifier.patch b/testing/catatonit/fix-undeclared-identifier.patch
new file mode 100644
index 00000000000..cbe2ae8eb13
--- /dev/null
+++ b/testing/catatonit/fix-undeclared-identifier.patch
@@ -0,0 +1,13 @@
+diff --git a/catatonit.c b/catatonit.c
+index db972d6..51d530b 100644
+--- a/catatonit.c
++++ b/catatonit.c
+@@ -34,6 +34,8 @@
+
+ #include "config.h"
+
++extern char **__environ;
++
+ static enum loglevel_t {
+ LOG_FATAL = 0,
+ LOG_ERROR = 1,