summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorNoel Kuntze <noel.kuntze@thermi.consulting>2021-08-07 00:28:37 +0200
committerAriadne Conill <ariadne@dereferenced.org>2021-08-07 01:18:35 +0000
commit7b3e6a43bc550dc59926507aca493fffd9fd8f43 (patch)
tree5a8dad4413ef237c2d54d67ccaf49afa6a5423f0 /testing
parent99f73fb39e910741ae7eaa0c3cf4d40cb8a7d09e (diff)
downloadaports-7b3e6a43bc550dc59926507aca493fffd9fd8f43.zip
testing/kopano-webapp-spellchecker: fix the custom unpack code
... to also extract into a new directory for other archive types other than tar.gz And also fix the source URL.
Diffstat (limited to 'testing')
-rw-r--r--testing/kopano-webapp-spellchecker/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/testing/kopano-webapp-spellchecker/APKBUILD b/testing/kopano-webapp-spellchecker/APKBUILD
index 3800aed0a75..aa26ff329b9 100644
--- a/testing/kopano-webapp-spellchecker/APKBUILD
+++ b/testing/kopano-webapp-spellchecker/APKBUILD
@@ -2,7 +2,7 @@
pkgname=kopano-webapp-spellchecker
pkgdesc="spellchecker plugin for kopano-webapp"
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
# ppc64le, mips64 and riscv64 blocked by libmdbx -> kopano-core
arch="noarch !ppc64le !mips64 !riscv64"
url="https://stash.kopano.io/projects/KWA/repos/spellchecker/browse"
@@ -12,7 +12,7 @@ depends="kopano-webapp php-enchant"
# kopano-core necessary for mapi php module
makedepends="apache-ant openjdk8 kopano-webapp-src"
source="
- kopano-webapp-spellchecker-$pkgver.zip::https://stash.kopano.io/rest/api/latest/projects/KWA/repos/spellchecker/archive?at=refs%2Ftags%2Fv$pkgver&format=tar.gz
+ kopano-webapp-spellchecker-$pkgver.zip::https://stash.kopano.io/rest/api/latest/projects/KWA/repos/spellchecker/archive?at=refs%2Ftags%2Fv$pkgver&format=zip
kopano-webapp-spellchecker.ini
"
@@ -48,23 +48,23 @@ unpack() {
$gunzip -c "$s" | tar -C "$new_root_dir" -x ;;
*.tar.bz2)
msg "Unpacking $s..."
- tar -C "$srcdir" -jxf "$s" ;;
+ tar -C "$new_root_dir" -jxf "$s" ;;
*.tar.lz)
msg "Unpacking $s..."
- tar -C "$srcdir" --lzip -xf "$s" ;;
+ tar -C "$new_root_dir" --lzip -xf "$s" ;;
*.tar.lzma)
msg "Unpacking $s..."
- unlzma -T 0 -c "$s" | tar -C "$srcdir" -x ;;
+ unlzma -T 0 -c "$s" | tar -C "$new_root_dir" -x ;;
*.tar.xz)
msg "Unpacking $s..."
local threads_opt
if [ "$(readlink -f "$(command -v unxz)")" != "/bin/busybox" ]; then
threads_opt="--threads=0"
fi
- unxz $threads_opt -c "$s" | tar -C "$srcdir" -x ;;
+ unxz $threads_opt -c "$s" | tar -C "$new_root_dir" -x ;;
*.zip)
msg "Unpacking $s..."
- unzip -n -q "$s" -d "$srcdir" ;;
+ unzip -n -q "$s" -d "$new_root_dir" ;;
esac
done
}
@@ -106,6 +106,6 @@ package() {
fi
}
sha512sums="
-21a5d5a7e4c7f09c9a8337837bb1293012529668956bc6dde9fa46865b771dbf5356251a790e2a506ecbbd8151c230716bbc11cc8f1be61dd06fb6045301492f kopano-webapp-spellchecker-2.0.1.zip
+59e05779047878fa3d79a56e0689b1336b209feffab352a38e441a3068290132b259b7fb6056f34ef66e9b404b4fb2342499ae8520899d7fac261e8879325ef1 kopano-webapp-spellchecker-2.0.1.zip
e8bf6c3fa6baf8638116a032a767dc5c4ab9e989c553e8d5f3510e3f6c8de8b23f6917bcb0a6203d1686bf98efb1b0b88d7d5c2c14909a3e3b0a70927fce20bb kopano-webapp-spellchecker.ini
"