summaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2020-01-21 13:41:06 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-01-25 22:12:04 +0100
commit08f73aa0901f1a1f16d720b38bc37300f2cf0bb1 (patch)
treeeebda9e767a78e512b587cd75735acec43090696 /testing
parent99f9d22adb974ebcff793e6eaeb343ddd1ff7048 (diff)
downloadaports-08f73aa0901f1a1f16d720b38bc37300f2cf0bb1.zip
testing/mustach: new aport
https://gitlab.com/jobol/mustach C implementation of mustache templating
Diffstat (limited to 'testing')
-rw-r--r--testing/mustach/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/mustach/APKBUILD b/testing/mustach/APKBUILD
new file mode 100644
index 00000000000..fcb15532b9e
--- /dev/null
+++ b/testing/mustach/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=mustach
+pkgver=0.99_git20200124
+_sha=62f2b3c5625de3292ea86ca92a077e162db75911 # contains fully qualified soname
+pkgrel=0
+pkgdesc="C implementation of mustache templating"
+url="https://gitlab.com/jobol/mustach"
+arch="all"
+license="Apache-2.0"
+makedepends="json-c-dev valgrind"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://gitlab.com/jobol/mustach/-/archive/$_sha/mustach-$_sha.tar.bz2"
+builddir="$srcdir/$pkgname-$_sha"
+
+build() {
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make -j1 DESTDIR="$pkgdir" PREFIX="/usr" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 AUTHORS README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/
+}
+sha512sums="d2cd892ff936d400b1776a298bad81b38289733b215c6d5ccd7601001e26282a57d9cdcab514c0b48a4109b156f398904e5f3304765b32bec6ad95c7749c8220 mustach-62f2b3c5625de3292ea86ca92a077e162db75911.tar.bz2"