summaryrefslogtreecommitdiff
path: root/testing/uni/APKBUILD
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-08-04 10:32:56 +0000
committerpsykose <alice@ayaya.dev>2022-08-04 12:33:04 +0200
commitd9e95826c086ba4b679198c1d458746d48ef8b3e (patch)
treedc0d717c8c3a045ec8b88fda24b5019b342782d4 /testing/uni/APKBUILD
parentc1b3caf678a639c1f902aad6dc4b8f0a1d600e97 (diff)
downloadaports-d9e95826c086ba4b679198c1d458746d48ef8b3e.zip
testing/*: add gocache vars
see cffbff77e1cf386d901febec4a35b2a905065514
Diffstat (limited to 'testing/uni/APKBUILD')
-rw-r--r--testing/uni/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/uni/APKBUILD b/testing/uni/APKBUILD
index e42a7ee1e89..624a1209283 100644
--- a/testing/uni/APKBUILD
+++ b/testing/uni/APKBUILD
@@ -11,8 +11,10 @@ makedepends="go"
options="!check" # no test files
source="$pkgname-$pkgver.tar.gz::https://github.com/arp242/uni/archive/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
+export GOCACHE="$srcdir/go-cache"
+export GOTMPDIR="$srcdir"
+export GOMODCACHE="$srcdir/go"
build() {
go build -v .