summaryrefslogtreecommitdiff
path: root/testing/mustache
diff options
context:
space:
mode:
authorThomas Kienlen <kommander@laposte.net>2021-05-18 21:56:11 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-05-20 10:08:39 +0000
commit907a2ed67e0ff7dbdc20433a4bbb2531ad029a25 (patch)
tree7d556ea4996e0de039b90497b4cfdc03a87787f4 /testing/mustache
parent356e0ead15e6e05d1790a211bfa200fce7bcef5f (diff)
downloadaports-907a2ed67e0ff7dbdc20433a4bbb2531ad029a25.zip
testing/mustache: new aport
Mustache text templates for modern C++ https://github.com/kainjow/Mustache
Diffstat (limited to 'testing/mustache')
-rw-r--r--testing/mustache/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/mustache/APKBUILD b/testing/mustache/APKBUILD
new file mode 100644
index 00000000000..95ae425ea5d
--- /dev/null
+++ b/testing/mustache/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Thomas Kienlen <kommander@laposte.net>
+# Maintainer: Thomas Kienlen <kommander@laposte.net>
+pkgname=mustache
+pkgver=4.1
+pkgrel=0
+pkgdesc="Mustache text templates for modern C++"
+url="https://github.com/kainjow/Mustache"
+arch="noarch" # header-only library
+license="BSL-1.0"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kainjow/Mustache/archive/v$pkgver.tar.gz"
+builddir="$srcdir/Mustache-$pkgver"
+
+check() {
+ make
+}
+
+package() {
+ install -D -m644 mustache.hpp "$pkgdir"/usr/include/mustache.hpp
+}
+
+sha512sums="609c876fc085d1331355ec1f0396e588edf1fb3ea6765abcd06043cc5f7288f015d6bb7fdeb560df78aab54ae8d97e934375de577b944a09c9ae93f9915e7aff mustache-dev-4.1.tar.gz"