summaryrefslogtreecommitdiff
path: root/testing/exercism/APKBUILD
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-08-04 10:32:56 +0000
committerpsykose <alice@ayaya.dev>2022-08-04 12:33:04 +0200
commitd9e95826c086ba4b679198c1d458746d48ef8b3e (patch)
treedc0d717c8c3a045ec8b88fda24b5019b342782d4 /testing/exercism/APKBUILD
parentc1b3caf678a639c1f902aad6dc4b8f0a1d600e97 (diff)
downloadaports-d9e95826c086ba4b679198c1d458746d48ef8b3e.zip
testing/*: add gocache vars
see cffbff77e1cf386d901febec4a35b2a905065514
Diffstat (limited to 'testing/exercism/APKBUILD')
-rw-r--r--testing/exercism/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/exercism/APKBUILD b/testing/exercism/APKBUILD
index 70ed9992786..7c3d066d38c 100644
--- a/testing/exercism/APKBUILD
+++ b/testing/exercism/APKBUILD
@@ -14,9 +14,14 @@ subpackages="
$pkgname-fish-completion
$pkgname-zsh-completion
"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/exercism/cli/archive/v$pkgver.tar.gz"
builddir="$srcdir"/cli-$pkgver
+export GOCACHE="$srcdir/go-cache"
+export GOTMPDIR="$srcdir"
+export GOMODCACHE="$srcdir/go"
+export GOFLAGS="$GOFLAGS -modcacherw"
+
prepare() {
default_prepare
@@ -25,9 +30,6 @@ prepare() {
}
build() {
- export GOPATH="$srcdir"
- export GOFLAGS="$GOFLAGS -modcacherw"
-
go build -o bin/exercism exercism/main.go
}