summaryrefslogtreecommitdiff
path: root/testing/dhewm3
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2021-04-03 22:17:10 +0300
committerprspkt <prspkt@protonmail.com>2021-04-03 19:24:11 +0000
commit2aca48e7a2317320b0f5c7e7eaf4099a2692556d (patch)
treed923990ace121dc4656808d497eaa095041c6bb1 /testing/dhewm3
parentbaf8e8488ea594dcdf067a0e5703a679125232d8 (diff)
downloadaports-2aca48e7a2317320b0f5c7e7eaf4099a2692556d.zip
testing/dhewm3: upgrade to 1.5.1
- Remove musl patch since it made it upstream. - Align CMake usage with newapkbuild template.
Diffstat (limited to 'testing/dhewm3')
-rw-r--r--testing/dhewm3/APKBUILD36
-rw-r--r--testing/dhewm3/fix-musl.patch31
2 files changed, 20 insertions, 47 deletions
diff --git a/testing/dhewm3/APKBUILD b/testing/dhewm3/APKBUILD
index 82e96cede2f..3b959c3785e 100644
--- a/testing/dhewm3/APKBUILD
+++ b/testing/dhewm3/APKBUILD
@@ -1,38 +1,42 @@
# Contributor: Díaz Urbaneja Diego <sodomon2@gmail.com>
# Maintainer: Díaz Urbaneja Diego <sodomon2@gmail.com>
pkgname=dhewm3
-pkgver=1.5.1_rc1
-_realver=1.5.1_PRE1
+pkgver=1.5.1
pkgrel=0
pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
url="https://dhewm3.org/"
-arch="x86_64 x86" #disabled for the other architectures due to compiling problems
+arch="x86_64 x86" # disabled for the other architectures due to compiling problems
license="GPL-3.0-only"
depends="curl libjpeg-turbo libvorbis sdl2 zlib libogg libpng libvorbis"
-makedepends="openal-soft-dev make cmake sdl2-dev zlib-dev libjpeg-turbo-dev libogg-dev libpng-dev libvorbis-dev"
+makedepends="cmake libjpeg-turbo-dev libogg-dev libpng-dev libvorbis-dev make
+ openal-soft-dev sdl2-dev zlib-dev"
options="!check" # make check not implemented
-source="$pkgname-$_realver.tar.gz::https://github.com/dhewm/dhewm3/archive/$_realver.tar.gz
- fix-musl.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/dhewm/dhewm3/archive/$pkgver.tar.gz
dhewm3.desktop
dhewm3.png"
-builddir="$srcdir/$pkgname-$_realver/neo"
+builddir="$srcdir/$pkgname-$pkgver/neo"
build() {
- cmake CMakeLists.txt \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DD3XP=1 \
- -DDEDICATED=1 .
- make
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=None \
+ -DD3XP=1 \
+ -DDEDICATED=1 \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "$srcdir"/dhewm3.desktop "$pkgdir/usr/share/applications/dhewm3.desktop"
install -Dm644 "$srcdir"/dhewm3.png "$pkgdir/usr/share/pixmaps/dhewm3.png"
}
-sha512sums="73b2c43e16a82bc1a4fd6646493e7c69049a3c3abaac2206436f10d6180d616ad38c2c3480538e2690654c2cb73ec1be47d312939d64fd92ce03aff7fe64ceba dhewm3-1.5.1_PRE1.tar.gz
-396b1b4fe1889abf14141887e4a490b6069234784fd934ee120c68bf868febf767cf900a59871453ebd3adf62bf74bc7fba2bf5169b4594b6e735e0888930566 fix-musl.patch
+sha512sums="b485cadea173e8cf36c04b01ccc8e2e1ab1354b174fd11c967e7e361b084bd96fd781494b7c416097d39ea2e15e69ad948c6600f16f711526a17c9546243a0fa dhewm3-1.5.1.tar.gz
377d34c4d9ab21b09a501431e1bf8d123d3655a47499a7664db85168e2f85b73c8792bc958026593299eac57449f813b10047beb302784cc53d096e1cc37efbd dhewm3.desktop
13f7a50d1f57d35bf582c3d99ff4dea4b18e60827f62aa640b7b43d419a3f4f478b45311d2abacfd2aa2f033c59f5c6253aa4916fc234b41eb6cc70d5eeac17c dhewm3.png"
diff --git a/testing/dhewm3/fix-musl.patch b/testing/dhewm3/fix-musl.patch
deleted file mode 100644
index f4b33eb0c52..00000000000
--- a/testing/dhewm3/fix-musl.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/sys/posix/posix_main.cpp
-+++ b/sys/posix/posix_main.cpp
-@@ -362,7 +362,7 @@
- static const int crashSigs[] = { SIGILL, SIGABRT, SIGFPE, SIGSEGV };
- static const char* crashSigNames[] = { "SIGILL", "SIGABRT", "SIGFPE", "SIGSEGV" };
-
--#if defined(__linux__) || defined(__FreeBSD__) || defined(__APPLE__)
-+#if ( defined(__linux__) && defined(__GLIBC__) ) || defined(__FreeBSD__) || defined(__APPLE__)
- // TODO: https://github.com/ianlancetaylor/libbacktrace looks interesting and also supports windows apparently
- #define D3_HAVE_BACKTRACE
- #include <execinfo.h>
---- a/sys/posix/posix_net.cpp
-+++ b/sys/posix/posix_net.cpp
-@@ -644,7 +644,7 @@
- return -1;
- }
-
--#if defined(_GNU_SOURCE)
-+#if defined(_GNU_SOURCE) && defined(TEMP_FAILURE_RETRY)
- // handle EINTR interrupted system call with TEMP_FAILURE_RETRY - this is probably GNU libc specific
- if ( ( nbytes = TEMP_FAILURE_RETRY( read( fd, data, size ) ) ) == -1 ) {
- #else
-@@ -701,7 +701,7 @@
- return -1;
- }
-
--#if defined(_GNU_SOURCE)
-+#if defined(_GNU_SOURCE) && defined(TEMP_FAILURE_RETRY)
- // handle EINTR interrupted system call with TEMP_FAILURE_RETRY - this is probably GNU libc specific
- if ( ( nbytes = TEMP_FAILURE_RETRY ( write( fd, data, size ) ) ) == -1 ) {
- #else