summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-08-29 05:27:59 +0000
committerAriadne Conill <ariadne@ariadne.space>2024-08-31 21:41:39 +0000
commit6cce1d0007e8e004a813f9ea097fc322226a58cd (patch)
tree5931c7df2a58eef3e6abf2885e1dd5bc766f00c4 /scripts
parent12faa27b1cae8b219cb6438549f14fe739619cd8 (diff)
downloadaports-6cce1d0007e8e004a813f9ea097fc322226a58cd.zip
scripts/bootstrap.sh: add libucontext to depends of full cross gcc
the GDC frontend requires GDC to build since GCC 12, and libucontext is required by GDC
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/bootstrap.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/scripts/bootstrap.sh b/scripts/bootstrap.sh
index 1017ae96ffd..86703a43a49 100755
--- a/scripts/bootstrap.sh
+++ b/scripts/bootstrap.sh
@@ -92,8 +92,13 @@ if ! CHOST=$TARGET_ARCH BOOTSTRAP=nolibc APKBUILD=$(apkbuildname musl) abuild up
CHOST=$TARGET_ARCH BOOTSTRAP=nolibc APKBUILD=$(apkbuildname musl) abuild -r
fi
-# Full cross GCC
+# Build libucontext without docs and pkgconfig file as a dependency for gcc-gdc
+EXTRADEPENDS_BUILD="gcc-pass2-$TARGET_ARCH" \
EXTRADEPENDS_TARGET="musl musl-dev" \
+CHOST=$TARGET_ARCH BOOTSTRAP=nobase APKBUILD=$(apkbuildname libucontext) abuild -r
+
+# Full cross GCC
+EXTRADEPENDS_TARGET="musl musl-dev libucontext-dev" \
CTARGET=$TARGET_ARCH BOOTSTRAP=nobase APKBUILD=$(apkbuildname gcc) abuild -r
# Cross build-base