summaryrefslogtreecommitdiff
path: root/main
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-28 16:26:41 +0000
committerpsykose <alice@ayaya.dev>2023-06-30 19:52:24 +0200
commit6403bd8d0948af49368691746038cec34f03ce28 (patch)
treefe1c3f3e851ce075955c6872533515daa424da83 /main
parentda4780262417a9446b7d13fe9bb7e83c54edb53d (diff)
downloadaports-6403bd8d0948af49368691746038cec34f03ce28.zip
main/libasr: remove
this is discontinued upstream: https://github.com/OpenSMTPD/libasr/ > Warning This repository is not updated and contains known issues > that are fixed in upstream OpenBSD. Please use the bundled version in > OpenSMTPD instead. opensmtpd (the only user of this), keeps an in-tree fixed copy instead.
Diffstat (limited to 'main')
-rw-r--r--main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch64
-rw-r--r--main/libasr/APKBUILD40
2 files changed, 0 insertions, 104 deletions
diff --git a/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch b/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
deleted file mode 100644
index a843125a5a1..00000000000
--- a/main/libasr/0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From fb2c3b37d1022d84506ca0815c7c888c4f08e90c Mon Sep 17 00:00:00 2001
-From: xentec <xentec@aix0.eu>
-Date: Sat, 11 Feb 2017 14:39:24 +0000
-Subject: [PATCH 2/3] Replace missing res_randomid() with the more secure
- arc4random()
-
----
- configure.ac | 2 ++
- openbsd-compat/openbsd-compat.h | 2 ++
- src/res_mkquery.c | 2 +-
- src/res_send_async.c | 2 +-
- 4 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 10aff04..fa0e896 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -87,6 +87,8 @@
- # libasr specific checks.
- #
-
-+LIBS="-lcrypto -lbsd $LIBS"
-+
- # This ought to be part of the generic compat library, but we don't want to force
- # linking against other libs (-lresolv for instance) in all cases.
- # It has to be improved at some point.
-diff --git a/openbsd-compat/openbsd-compat.h b/openbsd-compat/openbsd-compat.h
-index c30591c..9be2e0b 100644
---- a/openbsd-compat/includes/compat-stdlib.h
-+++ b/openbsd-compat/includes/compat-stdlib.h
-@@ -30,3 +30,5 @@
- long long strtonum(const char *nptr, long long minval, long long maxval,
- const char **errstr);
- #endif
-+
-+unsigned int arc4random(void);
-diff --git a/src/res_mkquery.c b/src/res_mkquery.c
-index 27ed21e..cce4029 100644
---- a/src/res_mkquery.c
-+++ b/src/res_mkquery.c
-@@ -57,7 +57,7 @@ res_mkquery(int op, const char *dname, int class, int type,
- ac = asr_use_resolver(NULL);
-
- memset(&h, 0, sizeof h);
-- h.id = res_randomid();
-+ h.id = arc4random();
- if (ac->ac_options & RES_RECURSE)
- h.flags |= RD_MASK;
- h.qdcount = 1;
-diff --git a/src/res_send_async.c b/src/res_send_async.c
-index a60aa0d..a0f4704 100644
---- a/src/res_send_async.c
-+++ b/src/res_send_async.c
-@@ -380,7 +380,7 @@ setup_query(struct asr_query *as, const char *name, const char *dom,
- as->as.dns.obuflen = 0;
-
- memset(&h, 0, sizeof h);
-- h.id = res_randomid();
-+ h.id = arc4random();
- if (as->as_ctx->ac_options & RES_RECURSE)
- h.flags |= RD_MASK;
- h.qdcount = 1;
---
-2.11.1
diff --git a/main/libasr/APKBUILD b/main/libasr/APKBUILD
deleted file mode 100644
index 851b0cbb19a..00000000000
--- a/main/libasr/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=libasr
-pkgver=1.0.4
-pkgrel=5
-pkgdesc="libasr is a free, simple and portable asynchronous resolver library"
-url="https://www.opensmtpd.org"
-arch="all"
-license="ISC"
-makedepends="mandoc bison openssl-dev>3 automake autoconf libtool libbsd-dev"
-subpackages="$pkgname-dbg $pkgname-static $pkgname-dev"
-source="https://github.com/OpenSMTPD/libasr/archive/$pkgver/libasr-$pkgver.tar.gz
- 0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
- "
-
-prepare() {
- default_prepare
- ./bootstrap
-}
-
-check() {
- gcc -L src/.libs -I src tests/asr_simple.c -lasr -o tests/asr_simple
- LD_LIBRARY_PATH=src/.libs ./tests/asr_simple
-}
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --mandir=/usr/share/man
- make
-}
-
-package() {
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="93ff4643c46cccb36e4981336dde198975499c1e48df6ed0fa8e57628ea05a8dc1d5159fe9d0ee99ff2e7ab418aa346668749aca8be2f3346f07d884e4818368 libasr-1.0.4.tar.gz
-693c2bfce2ca9397909a281b3d634b37608ff6286a4e9b3c1d638a337c585d307db4a325fb8b607ef45399c1ee05063eda5eb46060d804e5b4ad51ca6890846d 0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch"