summaryrefslogtreecommitdiff
path: root/main/openrc
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera <hugo@whynothugo.nl>2024-06-06 16:19:26 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-06-07 07:30:42 +0000
commitbd8f4a55320af2d94a5da3ffb4f956841f10d274 (patch)
treef30397efd4c7ab0049c6a2c541958ffcc7d80897 /main/openrc
parent9e03b74d2dd976cb936e8d41b27846db5ce9788f (diff)
downloadaports-bd8f4a55320af2d94a5da3ffb4f956841f10d274.zip
main/openrc: add documentation for modules-load
The *modules* service and *modules-load* isn't documented anywhere. Add a man page for it for the basic information that an administrator might need.
Diffstat (limited to 'main/openrc')
-rw-r--r--main/openrc/APKBUILD11
-rw-r--r--main/openrc/modules.7.scd31
2 files changed, 40 insertions, 2 deletions
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index af29e66468a..daddca09c70 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,14 +2,14 @@
pkgname=openrc
pkgver=0.54
_ver=${pkgver/_git*/}
-pkgrel=1
+pkgrel=2
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
license="BSD-2-Clause"
depends="ifupdown-any"
makedepends_host="bsd-compat-headers libcap-dev linux-headers"
-makedepends_build="meson"
+makedepends_build="meson scdoc"
checkdepends="sed"
subpackages="
$pkgname-dbg
@@ -48,6 +48,8 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/OpenRC/openrc/archive/$pkgve
sysctl.initd
machine-id.initd
test-networking.sh
+
+ modules.7.scd
"
options="!check" # not updated to meson build system, require makefile build
provides="ifupdown-ng-openrc=0.12.1-r4"
@@ -133,6 +135,10 @@ package() {
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
install -m644 ./*.md "$pkgdir"/usr/share/doc/$pkgname/
+ scdoc < "$srcdir/modules.7.scd" > modules.7
+ install -Dm644 modules.7 -t "$pkgdir/usr/share/man/man7/"
+ ln -s "/usr/share/man/man7/modules.7" "$pkgdir/usr/share/man/man7/modules-load.7"
+
# we use a virtual keymaps services to allow users to set their
# keymaps either with the OpenRC loadkeys service provided by
# the kbd aport or with the loadkmap service provided by the
@@ -194,4 +200,5 @@ d76c75c58e6f4b0801edac4e081b725ef3d50a9a8c9bbb5692bf4d0f804af7d383bf71a73d5d03ed
2d5f9f6d41b7c0a8643cfdee1ce3c399bfe4ebff54421f33ab1e74c1c4c1b96a49e54b5cd69f0339a060342e4e5a11067bbff68c39fa487919259d73e8e46ed1 sysctl.initd
a60129f4bed134a27773c61994d114b3a5d1ab9f20097b096956f5bb696c056f4a608577cabb34c32b51899c69dce3bd0d8ffa61f5b66fd00fc5085d1ebba54f machine-id.initd
af17947aa3954e317dc06580da829200e0b0f2ddc37ce842c3fc7fc0d8ca2f40220e4f4665f61b4b5ec47c96416db0127e2ed979b9421bf21df89d4c4f998b7f test-networking.sh
+edf23bbec3c67457f3039d193cd3a756a079ab080e5e3d87e724a1a0d9be86b82797bf2bf5280fbf33d1c60b98e3859d9d9c265f8119a84ccdcaa9937ab72296 modules.7.scd
"
diff --git a/main/openrc/modules.7.scd b/main/openrc/modules.7.scd
new file mode 100644
index 00000000000..dba656b4a72
--- /dev/null
+++ b/main/openrc/modules.7.scd
@@ -0,0 +1,31 @@
+modules(7)
+
+# NAME
+
+modules - Loads explicitly defined kernel modules
+
+# DESCRIPTION
+
+The *modules* service loads explicitly defined kernel modules during early
+startup. This service is enabled by default.
+
+The modules service will read configuration files matching the following
+patterns:
+
+- _/lib/modules-load.d/\*.conf_
+- _/usr/lib/modules-load\.d/\*.conf_
+- _/etc/modules_
+- _/etc/modules-load.d/\*.conf_
+- _/run/modules-load.d/\*.conf_
+
+If multiple files with the same name are found in different locations, only the
+one in the latter location is processed.
+
+# FILE FORMAT
+
+Files must contain exactly one module name per line. Empty lines and lines
+starting with # are ignored.
+
+# SEE ALSO
+
+modprobe(8)