summaryrefslogtreecommitdiff
path: root/main/ifupdown-ng
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-07-28 10:44:38 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-07-28 10:44:38 -0600
commit046973fa3ceb5c22ecac03ac83674e939e327b83 (patch)
tree5d4a1d0f7df377bbeb86bc60c4178e6eec67762e /main/ifupdown-ng
parent4edb63d403f342538280c51f3a572e46217af24e (diff)
downloadaports-046973fa3ceb5c22ecac03ac83674e939e327b83.zip
main/ifupdown-ng: move to main
Diffstat (limited to 'main/ifupdown-ng')
-rw-r--r--main/ifupdown-ng/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/ifupdown-ng/APKBUILD b/main/ifupdown-ng/APKBUILD
new file mode 100644
index 00000000000..dc54de9ca25
--- /dev/null
+++ b/main/ifupdown-ng/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ariadne Conill <ariadne@dereferenced.org>
+pkgname=ifupdown-ng
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="tools for managing network configuration"
+url="https://github.com/ifupdown-ng/ifupdown-ng"
+arch="all"
+license="ISC"
+depends=""
+checkdepends="kyua atf"
+makedepends="scdoc"
+install=""
+subpackages="$pkgname-doc"
+source="https://distfiles.dereferenced.org/ifupdown-ng/ifupdown-ng-$pkgver.tar.xz"
+builddir="$srcdir/ifupdown-ng-$pkgver"
+
+# We only install the core executors right now. The other executors are
+# still being ported to run under ifupdown-ng natively, and so we will
+# use the ifupdown scripts for now for those cases.
+_executor_scripts="dhcp ipv6-ra static link"
+
+build() {
+ make
+ make docs
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" EXECUTOR_SCRIPTS="$_executor_scripts" install install_docs
+}
+
+sha512sums="4343d5aff522dd545458a2309d4354b25321e9bf349e8f75777e1364065b236eaec8655b7c98148450a5600eeb8bb61ee7dbfb182ec3c55ee20562ed2d3f5a74 ifupdown-ng-0.4.2.tar.xz"