summaryrefslogtreecommitdiff
path: root/main/fstrm/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-08 16:15:20 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 12:38:37 +0000
commite306e7f50da240fab2f71e0ac9561485bc48d298 (patch)
tree7c5930edbbf523d3f990c9847a2c6913f7861322 /main/fstrm/APKBUILD
parent835fd3c4f8b94f2f248aa4d98c38595adc1bcd16 (diff)
downloadaports-e306e7f50da240fab2f71e0ac9561485bc48d298.zip
main/fstrm: move from community
Diffstat (limited to 'main/fstrm/APKBUILD')
-rw-r--r--main/fstrm/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/fstrm/APKBUILD b/main/fstrm/APKBUILD
new file mode 100644
index 00000000000..4a1ba80b734
--- /dev/null
+++ b/main/fstrm/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: tcely <tcely@users.noreply.github.com>
+# Maintainer: tcely <fstrm+aports@tcely.33mail.com>
+pkgname="fstrm"
+pkgver="0.5.0"
+pkgrel=0
+pkgdesc="Frame Streams implementation in C"
+url="https://github.com/farsightsec/fstrm"
+arch="all"
+# check failure on s390x reported upstream:
+# https://github.com/farsightsec/fstrm/issues/58
+license="MIT"
+depends=""
+depends_dev="libevent-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://dl.farsightsecurity.com/dist/$pkgname/$pkgname-$pkgver.tar.gz
+ reduce-testruns.patch"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ make check
+}
+
+package() {
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="cc60d8974d73d4f5327c46fe642151c88cf8d670ac9bb5db6cb5990b6c0995a0e09c9ae1a6c86ecbfd35fe03664b5402becd68bc6e81e83e9f4b84668d866f25 fstrm-0.5.0.tar.gz
+1c687ee7741fb20a571c3d7d3fb9a1cf09709d83d66d788eb09835750ee2313aa565f74d35a9cdece2154e1b8c41c68b268ca8f5bc33f8d14550ebe46880d550 reduce-testruns.patch"